[asterisk-users] Asterisk connectivity to Avaya SM

Thomas Peters TPeters at mcts.org
Wed Feb 27 10:09:17 CST 2019

Thanks for the reply John.

About 85-90% of what this box has to do is just handle calls, but it also has options to transfer calls to the main phone system, which up to now has been another asterisk box. For example, you can hit 6 to be transferred to the Lost & Found Department. 

I do have allowguest set to “yes” already, but of course I also have type=peer and the other stuff for a sip trunk.

The Avaya engineer is telling me that I need to change my “From” header, and I don’t know how to do that. 

I tried various things in sip.conf and now I get 
> sip show peer sessionmgr1
Callerid     : " at mcts.org" <>

My sip.conf file now has:
callerid=" at mcts.org"

I have to figure this out in the next few days, or I’m in deep doo-doo. 


Thomas M. Peters | Sr. Systems Administrator |  mailto:tpeters at mcts.org  

From: asterisk-users <mailto:asterisk-users-bounces at lists.digium.com> On Behalf Of John Kiniston
Sent: Tuesday, February 26, 2019 4:46 PM
To: Asterisk Users Mailing List - Non-Commercial Discussion <mailto:asterisk-users at lists.digium.com>
Subject: Re: [asterisk-users] Asterisk connectivity to Avaya SM

Does the Asterisk box need to do anything other than handle calls for this one specific IVR? IE does it ever originate calls?
If it's only recieving calls then I'd turn on guest access and not even bother with a peer.
Just set

On Tue, Feb 26, 2019 at 3:13 PM Thomas Peters <mailto:TPeters at mcts.org> wrote:
Hello all, I hope someone can help me with this old Asterisk version. I have to run this version because of a custom IVR written on it. Porting it would take much too long and we’d have to hire a consultant because of all the hooks it has into Oracle databases and real-time information. 
We have a brand-new Avaya phone system in place and we will be cutting over to it in late March 2019. 
• We have an Asterisk 13.3.2 server with no phones registered to it, acting as a PSTN gateway. Calls come into it and get distributed to other Asterisk boxes with phones. 
• If a call comes in from the provider marked as having been dialed as xxx-xxx-6711 (those are digits, not a pattern) it gets routed to the IVR box
• The IVR box runs Asterisk and a custom IVR.
Where we have to get to: 
• The new Avaya Session Manager has to have a working SIP trunk to the IVR so it can pass calls that come into xxx-xxx-6711 to it. 
What the problem is: 
• I don’t fully understand what’s going on here, neither how it works now, nor what I need to do to make Avaya’s SM happy.
• When I do sip show peers on my IVR box, I see the Avaya session manager: 
jerec*CLI> sip show peers
Name/username              Host                                    Dyn Forcerport ACL Port     Status
sessionmgr1                                                5060     OK (1 ms)
• The Avaya engineer says he is seeing “SIP/2.0 400 Bad FROM header” in his trace screen, and his SM status screen shows “500 NOT REACHABLE” as the status for our IVR.
o He says we are sending 
“asterisk” sip:asterisk@(null):0;tag=as682f2c53 
as the “From” in the SIP header.
• He wants us to send 
mailto: at mcts.org  
       or more likely 
<sip:mailto: at mcts.org>
• Pings from either end to the other work just fine. 
• nmap doesn’t show port 5060 open. It shows only port 22/tcp open. But then again, my main asterisk PBX doesn’t show that port open either. So I don’t think that means anything. 
The IVR machine (Asterisk sip.conf file has an old section for the old PSTN gateway, and a new section I just added for the session manager. 
Old section for existing connections to the IVR: 
The new section, with many failed experiments commented out, is after the [sipivr] section: 
;Some have suggested using canreinvite=no with Avaya- didn't try that yet
Nothing I tried seems to make it stop sending asterisk@(null) in the header. This is supposed to be a sip trunk, not an extension, so I think I should NOT be user a username or secret. I’m not even sure what promiscredir does, or if it’s helping or harming me. 
There’s virtually nothing in the logs about this connection, other than this: 
[Feb 26 16:05:42] NOTICE[32142] chan_sip.c: Peer 'sessionmgr1' is now Reachable. (1ms / 2000ms)
Can anyone help? 

Thomas M. Peters | Sr. Systems Administrator |  mailto:tpeters at mcts.org  
Desk: 414.343.1720 | Helpdesk: x3400 or  mailto:helpdesk at mcts.org
1942 N 17th Street | Milwaukee, WI  53205
Check us out on https://www.facebook.com/mcts & https://twitter.com/RideMCTS
-- Bandwidth and Colocation Provided by http://www.api-digital.com --

Check out the new Asterisk community forum at: https://community.asterisk.org/

New to Asterisk? Start here:

asterisk-users mailing list
To UNSUBSCRIBE or update options visit:

A human being should be able to change a diaper, plan an invasion, butcher a hog, conn a ship, design a building, write a sonnet, balance accounts, build a wall, set a bone, comfort the dying, take orders, give orders, cooperate, act alone, solve equations, analyze a new problem, pitch manure, program a computer, cook a tasty meal, fight efficiently, die gallantly. Specialization is for insects.

More information about the asterisk-users mailing list