[asterisk-users] Faxes stopped working - AMI issue?

Joshua C. Colp jcolp at sangoma.com
Tue Dec 3 16:21:21 CST 2019

On Tue, Dec 3, 2019 at 6:09 PM D'Arcy Cain <darcy at vybenetworks.com> wrote:

> On 12/3/19 3:04 PM, Joshua C. Colp wrote:
> >      >     The AMI command, after the login, looks like this:
> >      >
> >      >     Action: Originate
> >      >     Channel: SIP/outgoing/%%(destination)s
> >      >     Context: LocalSets
> >      >     CallerID: Vybe Consulting Inc Fax Service <5555551212>
> >      >     Exten: sendfax
> >      >     Priority: 1
> >      >     Timeout: 30000
> >      >     Variable: faxfile=%%(faxfile)s
> >      >     Variable: uid=%%(uid)s
> >      >     Variable: destination=%%(destination)s
> >      >     Variable: sender_name=Vybe Consulting Inc Fax Service
> >      >     Variable: sender_num=555555121 > Have you tried narrowing it
> down at all? Using the CLI to do a test
> > "channel originate" using the same dial string? Have you looked at what
> > comes back from AMI as a result of the Originate to see if it shows
> > anything?
> First of all, I really appreciate the help.
> So I tried this in the CLI: (everything is on one line)
> channel originate SIP/outgoing/5556667777 extension=sendfax at LocalSets
> faxfile=/path/to/tiff/file priority=1

The CLI command does not allow setting variables. It was more of a general
test to confirm the SIP portion and originating in general. The aim is to
narrow things down and verify things piece by piece.

> But I got "SendFAX requires an argument".  I tried various things but I
> am poking around in the dark.  Can you suggest an actual CLI command
> based on those options that I can try?
> Also, is there some way to have the AMI interface send back the same
> errors?  All I get from the socket now is "Asterisk Call Manager/5.0.1".

You'd be getting more from AMI than just that. A message comes back when
you login, another when you actually do the originate, as well as events
most likely before then. The Asterisk testsuite uses AMI heavily, as do
others, so I'm confident that AMI itself is working in that regard. You'd
need to look at your own AMI usage and ensure you are reading from the
socket and logging out. You could even connect over telnet and do the same
AMI action for Originate and test that way.

The "SendFAX requires an argument" is a normal log message which does not
go to manager.

Joshua C. Colp
Senior Software Developer
Sangoma Technologies
Check us out at www.sangoma.com and www.asterisk.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-users/attachments/20191203/a0faf1d4/attachment.html>

More information about the asterisk-users mailing list