[asterisk-users] Faxes stopped working - AMI issue?

D'Arcy Cain darcy at VybeNetworks.com
Tue Dec 3 16:08:58 CST 2019

On 12/3/19 3:04 PM, Joshua C. Colp wrote:
>      >     The AMI command, after the login, looks like this:
>      >
>      >     Action: Originate
>      >     Channel: SIP/outgoing/%%(destination)s
>      >     Context: LocalSets
>      >     CallerID: Vybe Consulting Inc Fax Service <5555551212>
>      >     Exten: sendfax
>      >     Priority: 1
>      >     Timeout: 30000
>      >     Variable: faxfile=%%(faxfile)s
>      >     Variable: uid=%%(uid)s
>      >     Variable: destination=%%(destination)s
>      >     Variable: sender_name=Vybe Consulting Inc Fax Service
>      >     Variable: sender_num=555555121 > Have you tried narrowing it down at all? Using the CLI to do a test
> "channel originate" using the same dial string? Have you looked at what 
> comes back from AMI as a result of the Originate to see if it shows 
> anything?

First of all, I really appreciate the help.

So I tried this in the CLI: (everything is on one line)

channel originate SIP/outgoing/5556667777 extension=sendfax at LocalSets 
faxfile=/path/to/tiff/file priority=1

But I got "SendFAX requires an argument".  I tried various things but I 
am poking around in the dark.  Can you suggest an actual CLI command 
based on those options that I can try?

Also, is there some way to have the AMI interface send back the same 
errors?  All I get from the socket now is "Asterisk Call Manager/5.0.1".

Thanks again.

D'Arcy J.M. Cain
Vybe Networks Inc.
IM:darcy at Vex.Net VoIP: sip:darcy at VybeNetworks.com

More information about the asterisk-users mailing list