[asterisk-users] Wanpipe 7 Driver problem with Debian 8.5 (Sangoma B600DE)

Julian Beach jb_soft at trink.co.uk
Tue Sep 13 17:51:18 CDT 2016

Hello Guillermo,

On Tuesday, September 13, 2016, 7:10:29 PM, you wrote:

> I have tried to install Wanpipe 7.0.20 in a fresh-installed Debian
> 8.5 (Jessie) server, but when I reach to the point where I have to
> enter the Linux Headers directory (installed in default with
> “apt-get install linux-headers-$(uname -r)”), I get an error, the
> package refuses to compile and installation aborts.

Wanpipe installs fill me with dread! Sangoma say that they only
support CentOS 6.x installs, and after many struggles to get Wanpipe
to work on Fedora versions, that is what I run it on (CentOS 6.7).
Even then, install issues are not uncommon, and it seems to be
particularly sensitive to kernel issues - I avoid kernel updates on my
Asterisk box!

I am currently running with kernel 2.6.32. Sangoma says that Wanpipe
will work on 4.3 kernels, but if your kernel is newer than 4.3
(November 2015) then that might be your problem.
"setup_drv_compile.log" is the place to look for clues. You should
find it in the directory where your Wanpipe source files are.

Best regards,
 Julian                            mailto:jb_soft at trink.co.uk

More information about the asterisk-users mailing list