[asterisk-users] Asterisk 1.8 Streaming MOH timing interface

Michael L. Young myoung at acsacc.com
Mon Feb 4 20:03:19 CST 2013

----- Original Message ----- 

> From: "Bob Pierce" <westmanbob at gmail.com>
> To: "Asterisk Users Mailing List - Non-Commercial Discussion"
> <asterisk-users at lists.digium.com>
> Cc: geed at westmancom.com
> Sent: Monday, February 4, 2013 6:14:26 PM
> Subject: [asterisk-users] Asterisk 1.8 Streaming MOH timing interface

> We are running Asterisk with an uptime of 40 weeks. Just
> today our streaming music on hold stopped working. I remember when
> we had first installed 1.8 we had an issue where the streaming music
> on hold would not work because Music On Hold was using the DAHDI
> timing module. We needed the DAHDI timing module loaded so that
> paging would work. However, at that time we upgraded to and
> the system loaded properly with both the dahdi and pthread timing
> module with Music On Hold using the pthread timing module. In that
> state, everything worked properly - Streaming Music On Hold worked
> as well as Paging. That has all continued to work properly for the
> last 40 weeks.

> I'm wondering of for some reason the Music on Hold service is now
> using the DAHDI timing module because when I do "module show like
> timing" I see:
> CLI> module show like timing
> Module Description Use Count
> res_timing_dahdi.so DAHDI Timing Interface 33
> res_timing_pthread.so pthread Timing Interface 0
> 2 modules loaded

> I believe that the pthread used to show a use count of at least 1
> with the Music On Hold service using that timing source. I suspec
> that if I restart the Asterisk service everything will come back up
> the way that it did last time. However, I'm wondering if there would
> be a way to switch the Music On Hold module back to using pthread
> timing without restarting the Asterisk service.

Bob, I would recommend upgrading to the latest version.  There have been a lot of security and bug fixes since 1.8.5.  There was a bug fixed, over a year ago (1.8.9), which sounds exactly like what you are experiencing.  The latest version is



More information about the asterisk-users mailing list