[asterisk-users] installing with yum

Albert Bonomo apeto2104 at gmail.com
Fri Aug 13 15:22:54 CDT 2010

You are right. I should fix my system first. It's a mess. I wasn't aware of
that until I started to work with it.
I know that asterisk is not so difficult to install form sources. I did it
once with no problem at all.
But I don't know why, this time my system is messed up. I sent the problem
to my provider but they haven
yet answered it. So I'll wait for an answer and then I'll go on with the

If the kernel of my system is provided by my server provider, what can I do
to fix this ?
The problem started when I tried :
yum install kernel-devel.
No package was found. So I started to ask people for help.
After that, it was clear that something was wrong ( not clear at least )
with my system.
uname -r  report something but
rpm -qa kernel\*  report something different.

Here you can see
[root at ns310181 ~]# uname -r

[root at ns310181 ~]# rpm -q kernel
package kernel is not installed

[root at ns310181 ~]# rpm -q kernel-devel
package kernel-devel is not installed

[root at ns310181 ~]# rpm -qa kernel\*

[root at ns310181 ~]# rpm -q fedora-release

I sent all this to my provider asking for help.
I'll wait for there answer.
Thanks for your comment.

2010/8/13 Matthew J. Roth <mroth at imminc.com>

> Albert Bonomo wrote:
> >
> > Well, I did tried using the source but couldn't make it work.
> > some problem with dependencies and kernel version.
> > It is really difficult to put all the stuff in order to make a source
> > work.
> Albert,
> It's really not that difficult if your system is in decent shape.
>  Unfortunately, from reading your posts on this subject in the Fedora users
> list <
> http://lists.fedoraproject.org/pipermail/users/2010-August/380371.html>, I
> know that you're working on a system that you didn't set up and it's a
> terrible mess.  As a matter of etiquette, this is information that you
> really should disclose to people when you ask them for help.
> You need to fix the underlying problems before you attempt to go any
> further with that system.  You are trying to force your way through some
> serious issues, and I wouldn't trust any software that you manage to get
> installed via source or the package manager.  My suggestion is to start with
> a clean and fully updated install of CentOS.  If that's not possible, go
> with the most recent version of Fedora available, but be warned that it has
> a very short support cycle which isn't ideal for production servers.
> You may experience some difficulty coming up to speed with Linux, but rest
> assured that Asterisk is not difficult to install from source if the right
> foundation is in place.  People will be willing and able to help you along
> the way if you're following a sensible path.
> Regards,
> Matthew Roth
> InterMedia Marketing Solutions
> Software Engineer and Systems Developer
> --
> _____________________________________________________________________
> -- Bandwidth and Colocation Provided by http://www.api-digital.com --
> New to Asterisk? Join us for a live introductory webinar every Thurs:
>               http://www.asterisk.org/hello
> asterisk-users mailing list
> To UNSUBSCRIBE or update options visit:
>   http://lists.digium.com/mailman/listinfo/asterisk-users

@apetob at Tweeter

There are only 10 types of people in the world:
Those who understand binary and those who don't
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.digium.com/pipermail/asterisk-users/attachments/20100813/4a87dc75/attachment.htm 

More information about the asterisk-users mailing list