[asterisk-users] No Audio with SIP to only one provider when switching servers

Hadar Pedhazur hadar at unorthodox.com
Wed Apr 25 15:13:27 MST 2007

I have been running Asterisk for years on a machine with a public 
IP. Most recently, I have been running 1.2.17, from the day it 
came out, with no (noticeable) problems.

Yesterday, I switched over to a new server that is on the same 
public subnet, one higher than the original server.

I built 1.2.17 from source on that machine (as I did on the old 
server). My firewall on the new machine is configured identically 
to the old one as well.

All of my IAX connections just worked. All but one of my SIP 
connections just worked as well (which is why I can't believe it's 
a firewall issue).

StanaPhone, which I use for 2 incoming DIDs, registers correctly, 
and rings my phones correctly when a call comes in. However, once 
answered, there is dead silence in both directions, on 100% of the 

There isn't any problem on StanaPhone's side (which has provided a 
_fantastic_ service ever since I signed up!), because I can 
connect to them with X-Lite and receive calls with audio. More 
importantly, if I fire up Asterisk on the old server, it still 
works!!! I can connect with X-Lite to the new server, so the new 
server definitely accepts SIP connections, and audio works.

It's _not_ a codec problem. I verified that on both the working 
and non-working servers the connection is established with ulaw on 
both sides.

I have dumped the "peer" and the "channel" on both, while the call 
was active, and they look identical to me, except for the random 
bits associated with a particular connection. Here are the ones 
from the machine that fails:

*CLI> sip show peer XXXXXXXXXX

   * Name       : XXXXXXXXXX
   Secret       : <Set>
   MD5Secret    : <Not set>
   Context      : default
   Subscr.Cont. : <Not set>
   Language     :
   AMA flags    : Unknown
   CallingPres  : Presentation Allowed, Not Screened
   Callgroup    :
   Pickupgroup  :
   Mailbox      :
   VM Extension : asterisk
   LastMsgsSent : 32767/65535
   Call limit   : 0
   Dynamic      : No
   Callerid     : "" <>
   Expire       : -1
   Insecure     : port,invite
   Nat          : RFC3581
   ACL          : No
   CanReinvite  : No
   PromiscRedir : No
   User=Phone   : No
   Trust RPID   : No
   Send RPID    : No
   DTMFmode     : rfc2833
   LastMsg      : 0
   ToHost       : sip.stanaphone.com
   Addr->IP     : Port 5060
   Defaddr->IP  : Port 0
   Def. Username: 12345678
   SIP Options  : (none)
   Codecs       : 0x4 (ulaw)
   Codec Order  : (ulaw)
   Status       : OK (20 ms)
   Useragent    :
   Reg. Contact :

new*CLI> sip show channel 
14cdca3b6c900b1a54dcad2547234596 at sip.stanaphone.com

   * SIP Call
   Direction:              Outgoing
   Call-ID: 14cdca3b6c900b1a54dcad2547234596 at sip.stanaphone.com
   Our Codec Capability:   4
   Non-Codec Capability:   1
   Their Codec Capability:   4
   Joint Codec Capability:   4
   Format                  ulaw
   Theoretical Address:
   Received Address:
   NAT Support:            RFC3581
   Audio IP:               AAA.BBB.CCC.DDD (local)
   Our Tag:                as360c7ca5
   Their Tag:              0bd46ffd48e4fbffb3a68f13f8ad2599
   SIP User agent:
   Username:               87654321
   Peername:               12345678
   Original uri:           sip:
   Need Destroy:           0
   Last Message:           Tx: ACK
   Promiscuous Redir:      No
   Route:                  sip:;ftag=as360c7ca5;lr=on
   DTMF Mode:              rfc2833
   SIP Options:            (none)

Finally, I built 1.2.18 from source today, and everything is 
working perfectly _except_ for StanaPhone, which continued to 
connect with no problems, but deliver no audio in either direction.

I have no idea what else to try, and would appreciate _any_ guidance.

Thanks in advance!

More information about the asterisk-users mailing list