[Asterisk-Users] Call dropping out after 5s: Solution!

Jean-Yves Avenard jean-yves.avenard at hydrix.com
Tue Jun 29 06:36:50 MST 2004

Hash: SHA1


I'm the one who posted a message about the fact that nobody answer 
anymore to questions asked.

I posted two days ago a problem I was facing that calls made over the 
Internet to my Asterisk gateway would hang-up after just 5s (no NAT 
were involved)
Answer I got was: it's your config

Well, it wasn't (as I was expecting).
I compiled Asterisk under a Linux RedHat 9 PC, I copied across all the 
config files from the FreeBSD server to the Linux PC.
Started asterisk, registered the phone: all worked fine first go, and 
guess what?? No drop after 5s.

I guess the FreeBSD support is just not up to scratch. So if anybody is 
having this problem, just try to find an old PC somewhere load linux 
and up you go. This will raise the cost of our Asterisk installation as 
we now have to include an extra PC (all our servers are FreeBSD).

Many people have responded to my complaint that there was a lot of 
information available and basically people should just read it. My 
point is: do not always assume people did not read available 
documentation. For the past 4 days I've read the almost entire wiki 
site ; I looked at almost all messages sent to this distribution list 
that was somehow related to my problem: no luck.

I also faced another problem today. Encouraged by the progress with the 
Linux server, I configured the TDM03B (3 FXO ports). Loaded the kernel 
module, no problem card was recognized. Started asterisk, tried to make 
a call:
- - -Can start Zap channel

try about a dozen different configuration ; no luck. As I ran into 
similar problem with my FreeBSD box, I thought: there's no way it can 
be the driver this time (TDM driver on FreeBSD is an early beta)
So I opened the Linux PC, moved the card from one PCI slot to another.
Tried again as above: no luck.

Open the PC again, move the card into the third and last PCI slot. 
Disabled the USB 2.0 host controller that was sharing the same IRQ (7).
Start asterisk, dial: It works!

So now which PCI slot your card is in makes a difference! Something 
very fishy here.

Was this documented? I didn't find anything like that whatsoever. I 
guess this could be added somewhere


- ---
Jean-Yves Avenard
Hydrix Pty Ltd - Embedding the net
www.hydrix.com | fax +61 3 95093717 | phone +61 3 9509 3724
Version: GnuPG v1.2.4 (Darwin)


More information about the asterisk-users mailing list