[Asterisk-code-review] bridge softmix: Avoid warning about an uninitialized variable. (asterisk[master])
Corey Farrell
asteriskteam at digium.com
Fri Jan 5 11:08:27 CST 2018
Corey Farrell has posted comments on this change. ( https://gerrit.asterisk.org/7819 )
Change subject: bridge_softmix: Avoid warning about an uninitialized variable.
......................................................................
Patch Set 1: Code-Review-1
(1 comment)
https://gerrit.asterisk.org/#/c/7819/1/bridges/bridge_softmix.c
File bridges/bridge_softmix.c:
https://gerrit.asterisk.org/#/c/7819/1/bridges/bridge_softmix.c@1407
PS1, Line 1407: check_binaural_position_change(bridge, softmix_data, bridge_channel);
I assume the uninitialized variable warning comes from here? If so I'm not sure if this call should always use bridge_channel == NULL, or if check_binaural_position_change should be called from within the bridge->channels traversal? I don't know anything about the binaural code so I could be wrong.
If this function is intended to be called with a NULL 3rd parameter I think we should just pass NULL explicitly, rather than passing a NULL bridge_channel variable. That way if code order changes in the future and bridge_channel gets reset before this call we won't use the wrong value.
--
To view, visit https://gerrit.asterisk.org/7819
To unsubscribe, visit https://gerrit.asterisk.org/settings
Gerrit-Project: asterisk
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I8af3bd84656b685a956d498459f8db3613f68954
Gerrit-Change-Number: 7819
Gerrit-PatchSet: 1
Gerrit-Owner: Alexander Traud <pabstraud at compuserve.com>
Gerrit-Reviewer: Alexander Traud <pabstraud at compuserve.com>
Gerrit-Reviewer: Corey Farrell <git at cfware.com>
Gerrit-Reviewer: Jenkins2
Gerrit-Comment-Date: Fri, 05 Jan 2018 17:08:27 +0000
Gerrit-HasComments: Yes
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-code-review/attachments/20180105/cef17b87/attachment.html>
More information about the asterisk-code-review
mailing list