[asterisk-app-dev] Call recording using ARI

Matthew Jordan mjordan at digium.com
Mon Sep 22 19:33:21 CDT 2014

On Mon, Sep 22, 2014 at 3:37 PM, Jan Svoboda <jan at mluv.cz> wrote:

>  Hello,
> the “recording” directory was missing, and creating it in
> "/var/spool/asterisk/recording” did solve the issue, thanks.
> Still not sure if this is the correct behaviour. I have tried it before
> giving absolute path like “/tmp/test”, expecting it would try to create the
> file in “/tmp”, not in "/var/spool/asterisk/recording/tmp”.
> So right now, passing “/tmp/test” (absolute) and “tmp/test” (relative)
> paths have the same effect.
That's the expected behavior.

Allowing remote users to create files in random locations on the server is
generally a bad idea. The paths that you specify are all relative to
/var/spool/asterisk/recording (or rather, the Asterisk recording directory).


Matthew Jordan
Digium, Inc. | Engineering Manager
445 Jan Davis Drive NW - Huntsville, AL 35806 - USA
Check us out at: http://digium.com & http://asterisk.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-app-dev/attachments/20140922/d5eac717/attachment.html>

More information about the asterisk-app-dev mailing list