[asterisk-dev] [Code Review] 3104: PJSIP CLI Part 2
Mark Michelson
reviewboard at asterisk.org
Thu Jan 16 10:32:11 CST 2014
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviewboard.asterisk.org/r/3104/#review10599
-----------------------------------------------------------
branches/12/res/res_pjsip/config_auth.c
<https://reviewboard.asterisk.org/r/3104/#comment20078>
No need to use RAII_VAR for s_container.
branches/12/res/res_pjsip/config_auth.c
<https://reviewboard.asterisk.org/r/3104/#comment20079>
Check these for failure.
branches/12/res/res_pjsip/config_transport.c
<https://reviewboard.asterisk.org/r/3104/#comment20080>
No need for RAII_VAR for s_container.
branches/12/res/res_pjsip/config_transport.c
<https://reviewboard.asterisk.org/r/3104/#comment20081>
Check these for failure.
branches/12/res/res_pjsip/config_transport.c
<https://reviewboard.asterisk.org/r/3104/#comment20082>
Instead of using alloca, just use an array. Also, 256 is way too large an allocation for printing an IP address and port. You can do this instead:
char hoststr[PJ_INET6_ADDRSTRLEN];
Then later, when you call pj_sockaddr_print, you can use sizeof(hoststr) as the third argument.
branches/12/res/res_pjsip/location.c
<https://reviewboard.asterisk.org/r/3104/#comment20083>
Another case where s_container doesn't need to use RAII_VAR.
branches/12/res/res_pjsip/location.c
<https://reviewboard.asterisk.org/r/3104/#comment20084>
Another case where you should check for failure.
branches/12/res/res_pjsip/location.c
<https://reviewboard.asterisk.org/r/3104/#comment20085>
Like with previous s_containers:
1) No need for RAII_VAR for child_container.
2) Check all potential failure paths for failure.
branches/12/res/res_pjsip/pjsip_configuration.c
<https://reviewboard.asterisk.org/r/3104/#comment20086>
Same comments as with previous s_containers.
branches/12/res/res_pjsip_endpoint_identifier_ip.c
<https://reviewboard.asterisk.org/r/3104/#comment20073>
All of these need to be checked for failure.
branches/12/res/res_pjsip_endpoint_identifier_ip.c
<https://reviewboard.asterisk.org/r/3104/#comment20074>
Why 14?
branches/12/res/res_pjsip_outbound_registration.c
<https://reviewboard.asterisk.org/r/3104/#comment20076>
I'll stand in for Josh and state that the use of RAII_VAR is gratuitous for s_container since the goal is to actually end up returning it.
branches/12/res/res_pjsip_outbound_registration.c
<https://reviewboard.asterisk.org/r/3104/#comment20077>
More magic numbers here. What is 53?
- Mark Michelson
On Jan. 6, 2014, 9:49 p.m., George Joseph wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviewboard.asterisk.org/r/3104/
> -----------------------------------------------------------
>
> (Updated Jan. 6, 2014, 9:49 p.m.)
>
>
> Review request for Asterisk Developers.
>
>
> Repository: Asterisk
>
>
> Description
> -------
>
> Adds identify, transport and registration support to the CLI.
> Creates 3 additional callbacks, one for an iterator, one for a comparator and one for a container. This eliminates the link dependency from higher level modules to lower level ones.
> Eliminates duplicate sorting.
> Cleans up output formatting.
> Pushes cli registration down to the implementing source file.
> Adds several ast_sip_destroy_sorcery functions to complement existing ast_sip_sorcery_initialize functions. The destroy functions unregister cli commands and cli formatters.
>
>
> Diffs
> -----
>
> branches/12/res/res_pjsip_outbound_registration.c 405000
> branches/12/res/res_pjsip_endpoint_identifier_ip.c 405000
> branches/12/res/res_pjsip/pjsip_configuration.c 405000
> branches/12/res/res_pjsip/pjsip_cli.c 405000
> branches/12/res/res_pjsip/location.c 405000
> branches/12/res/res_pjsip/config_transport.c 405000
> branches/12/res/res_pjsip/config_auth.c 405000
> branches/12/include/asterisk/res_pjsip_cli.h 405000
> branches/12/include/asterisk/res_pjsip.h 405000
>
> Diff: https://reviewboard.asterisk.org/r/3104/diff/
>
>
> Testing
> -------
>
>
> Thanks,
>
> George Joseph
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-dev/attachments/20140116/4b4ddfb0/attachment-0001.html>
More information about the asterisk-dev
mailing list