[asterisk-users] Asterisk 18 won't transcode DTMF to inband

Kingsley Tart - Barritel Ltd kingsley.tart at barritel.com
Tue Oct 19 12:58:07 CDT 2021


I tried to find the precise version but I got stuck at this point:

# asterisk -V
Asterisk GIT-master-cc127a999cM

Within /usr/src/asterisk I tried this

# grep -riE 'version\b *18' .

but it didn't match any lines. So I'm not quite sure what actual
version this is. Any idea how I can tell from the GIT string?

Regarding the debugging, thanks, that's useful. I've emailed the
carrier so that we can schedule another test. I'll post the results
here when we can do some more test calls with the debugging enabled.


On Tue, 2021-10-19 at 13:53 -0300, Joshua C. Colp wrote:
> On Tue, Oct 19, 2021 at 11:46 AM Kingsley Tart <kingsley at dns99.co.uk>
> wrote:
> > I forgot to mention that pjsip.conf for this endpoint (that doesn't
> > support telephone-event) already has this:
> > 
> > dtmf_mode=auto
> What version of 18? Have you enabled Asterisk debug[1] and looked to
> see if it showed anything? Does Echo behave the same way?
> [1] 
> https://wiki.asterisk.org/wiki/display/AST/Collecting+Debug+Information

More information about the asterisk-users mailing list