[asterisk-users] Problem with the DB() function

Ira ira at extrasensory.com
Sat Mar 2 22:10:29 CST 2019

Hello Ira,

So the new install is coming along. I hooked up the new box for a couple of hours and got a bunch more problems worked out. And yet some still remain. I have this subroutine I call occasionally:

exten => 1,1,set(DB(forwards/calls)=${home_in})
   same => n,set(DB(forwards/number)=1)
   same => n,verbose(${DB(forwards/calls)})
   same => n,return

I can see the code running on the console and it prints out the first line with  ${home_in} replaced with the expected 80 or so characters that variable contains.

But the third line which should print those 80 characters back to the screen prints an empty string.  What might I be doing wrong. It's worked from version 2 or 3 through 13 but it seems to be broken in 16.

Also, when I installed asterisk it did not set itself up to start when the machine boots. Is there something else I need to do?  It's the most recent Fedora.

-- Ira 

More information about the asterisk-users mailing list