[asterisk-users] trying to upgrade asterisk and Debian -- not working (John Covici)

Stefan Viljoen viljoens at verishare.co.za
Thu Jan 24 00:17:32 CST 2019

What procedure did you follow to revert back to the old version?

It sounds like your binary has been revereted, but the modules it needs to load are still the 13.24.0-rc1 modules...

Hi.  I am trying to upgrade my asterisk from 13.15 to the latest of asterisk 13 which seems to be 13.24.0-rc1.  At the same time I want to go from Debian 8 to DEbian 9 to get a more recent operating system and applications.

I ran in to the following problems when trying to do this.

When trying to use asterisk 13.24.0-rc1, I ran into some strange problems with some of my custom scripts.

It seems the following statement immediately disconnects the user exten => s,n,Read(digit,,1,,1,20) ; read a digit

In the log after that statement it says user disconnected.  I have an agi which speaks some text before the read and that agi does not even say anything, although it does complete.

Now, if I try to go back to 13.15.0, it does not work at all because it keeps telling in my log that modules support is not available, so no modules get loaded.

Any ideas on thispuzzle would be appreciated.

Your life is like a penny.  You're going to lose it.  The question is:
How do
you spend it?

         John Covici wb2una
         covici at ccs.covici.com


Subject: Digest Footer

--Bandwidth and Colocation Provided by http://www.api-digital.com--

Check out the new Asterisk community forum at: https://community.asterisk.org/

New to Asterisk? Start here:

asterisk-users mailing list
To UNSUBSCRIBE or update options visit:


End of asterisk-users Digest, Vol 173, Issue 21

More information about the asterisk-users mailing list