[asterisk-users] Asterisk - can't hear other side. Or other side does not hear us

Ivan Demkovitch idemkovitch at yahoo.com
Wed Feb 27 17:26:17 CST 2019

Antony, thanks for response!
It wasn't technical, now it's getting there :)
1. It's asterisk 13.1-cert12. Network. I actually tried multiple things initially but now it's plain vanilla. No NAT. I have Asterisk on our network. All of our phones is IN our network as well, same subnet. All internal. Asterisk is NOT exposed to internet, noone connects to Asterisk from internet. We use Callcentric for VOIP trunk. External callers get in via Callcentric.
We have Mikrotik router and SIP handlers were disabled from beginning
I gathered more info now about 3 issues we seen1. Outside caller calls us but can't hear us. I beleive they talked to their phone provider and it works now?2. We have one caller where EVERY time they call - they can't hear us. They just say "ok, call us back". We call back and it works :)3. We have one caller where when we call them - they cannot hear us, but we can hear them. They called back - all works.
So, as you see we don't have NAT stuff
callcounter=yes                 ; This is to enable device state for queues

I feel like we need to trace SIP protocol. How do I do that? I may get on of those callers to work with us on testing.

> Hello,> This is not technical post,
Hm, no?
> just looking for suggestions on what to check.I have asterisk for long time,
Which version?

> no updates, just maintain OS updates. I use SPA504G phones.
Tell us about your network - where is Asterisk (inside your network, 
externally hosted on public IP address, other), where are your phones (inside 
one network (maybe the same as Asterisk is on), randomly distributed around 
the Internet, other), how do external callers manage to contact you?

> Very rarely and randomly when we pickup a phone - other side does not hear> us. Call them back and all works. Now I have couple people I'm talking to> and it seems like very call like this. Someone can't hear someone. Don't> know where to start to troubleshoot and what to look for.
Short answer: NAT

Longer answer: Check the type of firewall / router / NAT device you have 
between Asterisk and the phones (most likely at the telephone end) and see 
whether it offers "SIP ALG" (Application Layer Gateway) - if it does, turn it 

Also, check the sip.conf definitions you have for the phones which are affected 
by this, and make sure you have NAT set to one of yes, force_rport or comedia 
(you may hav eto experiment to see which works best in your environment).

Check https://www.voip-info.org/asterisk-sip-nat/ for some guidance.

https://www.voip-info.org/asterisk-sip-nat-solutions/ may also give you some 
further clues.

On the other hand, note that https://www.voip-info.org/asterisk-config-sipconf/ 
is woefully outdated (at least as far as NAT is concerned).

If none of that helps, I suggest doing a SIP packet trace at the server (and 
at the phone end if you can) and see what addresses are being passed between 
the two for RTP.  That should tell you why one end can't contact the other.



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-users/attachments/20190227/78bf7abb/attachment.html>

More information about the asterisk-users mailing list