[asterisk-users] One Touch Record and a matching entry in sip.conf

David Cunningham dcunningham at voisonics.com
Wed Dec 11 03:16:54 CST 2019


This has a bit of a long explanation... ultimately the question is why
adding a section to sip.conf made a difference to One Touch Record.

We're implementing a recording toggle using the "Record" button on a SIP
telephone and Asterisk's "One Touch Record" feature in features.conf.

It worked without problem when the calling party pressed the Record button,
but it didn't work when the called party pressed the Record button. When
the called party pressed the button Asterisk logged "Recording requested,
but no One Touch Monitor registered. (See features.conf)", even though it
was certainly enabled in features.conf

The destination was called with a dial string like SIP/1111 at
Eventually we worked out that adding a section to sip.conf like this
allowed it to start working:

type = friend
... etc..

We already (before it started working) had a section almost identical but
without the port in the section name:
type = friend
... etc..

The question is, why did adding the section with the port in the name make
a difference? Is it because only Asterisk sip users (of which a friend is
one) are allowed to use One Touch Record? If so I don't see this documented
anywhere. Note that adding or removing the 'w' or 'W' options to the Dial
seems to make no difference at all, and following the addition of the
sip.conf section it works without either of these options in the Dial.

Thank you in advance for any insight into this.

David Cunningham, Voisonics Limited
USA: +1 213 221 1092
New Zealand: +64 (0)28 2558 3782
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-users/attachments/20191211/cc358582/attachment.html>

More information about the asterisk-users mailing list