[asterisk-users] Only 8kHz recorded after disallowing all but G722 codec on inbound

David P davidswalkabout at gmail.com
Sat Jun 30 17:41:34 CDT 2018

To followup my question below, we're looking for a way to record in
Asterisk at 16kHz but send only 8kHz (ulaw) to our peers. Is this possible?

Btw, I wanted to ask this as a followup to
https://community.asterisk.org/t/change-sample-rate-to-16khz/73842/2 but
whenever I try to login to that site, I get "Sorry, there was an error
authorizing your account. Perhaps you did not approve authorization?" I've
never received an email asking to verify my address, if that's what this
error means. I just tried re-registering, too.

On Sun, Jun 17, 2018 at 7:25 PM David P <davidswalkabout at gmail.com> wrote:

> I also just tried adding this:
>  same => n,Set(SIP_CODEC_INBOUND=g722)
> On Sat, Jun 16, 2018 at 4:36 PM David P <davidswalkabout at gmail.com> wrote:
>> We want to record inbound channels at 16kHz, but send only 8kHz to our
>> peers. I've set our default profile in sip.conf to disallow all but g722,
>> and the peers disallow all but ulaw. We have a proxy in front of Asterisk
>> that is configured to disallow all but G722 also.
>> My test calls show inbound to the proxy is recorded at 16kHz, inbound in
>> Asterisk is only 8kHz, and the peers receive 8kHz. So the only thing not
>> working is Asterisk's sampling rate on inbound, and it seems to be
>> downsampling.
>> After a lot of web searching, I can't find any explanation of why we're
>> not getting 16kHz for G722. We're using Asterisk 14.7.6.
>> Cheers,
>> David
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-users/attachments/20180630/2b0c9767/attachment.html>

More information about the asterisk-users mailing list