[asterisk-users] asterisk and Hyper-V

Dmitriy Ermakov demonihin at gmail.com
Mon Dec 18 01:48:19 CST 2017

Hi, Kseniya!

I have three installations of Asterisk (as FreePBX but I think it is not
important). They work fine.

I have made some settings in Asterisk and Hyper-V:

Asterisk: timing interface - timerfd.


 1. Virtual Machine => Network Adapter => Hardware Acceleration =>
    Virtual Machine Queue - Disable it;
 2. Virtual Machine => Processor => Virtual Machine Reserve (percentage)
    - set at least 25% (if you have 4 virtual cores for your Asterisk).
    You can try to set reserve more or less then 25% - test it and,
    please, send email here;
 3. Virtual Machine => Integration Services => Time synchronisation -
    enable it.

This settings helped me.

Also check your Linux Kernel version - it must be 3.10 or newer. I saw
very bad "timing test" results on kernel 2.6.32.

On 12/18/2017 10:26 AM, Kseniya Blashchuk wrote:
> Hi all!
> Does anybody have experience with asterisk on Hyper-V? My test setup
> with Ubuntu 16 and asterisk 13.1 (ubuntu repo) shows sound distortion.
> I have analyzed the RTP flow with wireshark and I see high skew and
> delta values when the traffic leaves the hypervisor, however
> everything is okay when a capture is taken from a VM itself. I have
> read that there can be timing problems with Hyper-V. I have tried to
> disable time sync with the machine and tried different clocksources. I
> have also tried to change asterisk timing interface to dahdi (dummy) -
> nothing helped so far. Hyper-V version is 12p2.
> Does anybody have a working setup with Hyper-V?

С уважением, Дмитрий Ермаков

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-users/attachments/20171218/56c97b72/attachment.html>

More information about the asterisk-users mailing list