[asterisk-users] IAX2 getting stuck

Carlos Chavez cursor at telecomab.mx
Wed Apr 19 16:35:24 CDT 2017

On 4/19/17 4:23 PM, Antony Stone wrote:

> On Wednesday 19 April 2017 at 23:14:46, Carlos Chavez wrote:
>> On 4/19/17 4:09 PM, Antony Stone wrote:
>>> On Wednesday 19 April 2017 at 22:54:51, Carlos Chavez wrote:
>>>>         I have a server that had been operating for a few years now with
>>>> IAX2 trunks to several other servers.  Since yesterday all IAX2 trunks
>>>> now say UNREACHABLE.
>>> ...snip...
>>>> So far the only thing different is that the receive queue for port 4569
>>>> is not zero like all the other servers:
>>>> udp   128760      0      *
>>>>         Basically all packets for IAX2 are getting stuck in the queue.
>>>>         Any
>>>> suggestions?
>>> Have you tried rebooting the router which connects this machine to the
>>> Internet?
>>> It sounds like a stale connection-tracking table entry to me.
>>> Antony.
>>       We have already tried that.  One of the servers that has an IAX
>> trunk to this server is on the same local network so that eliminates any
>> firewall/router in the way.  We disabled iptables just in case too.
> Hm :(
> You say the USB ethernet adapter got unplugged and then reconnected...
> 1. What's the name of the network device for this adapter?  Is it the same
> name as it previously had?
> 2. What does 'ifconfig' say the IP address is for this adapter?
> 3. What do you have in /etc/asterisk/iax.conf for 'bindaddr' and 'bindport'?
> 4. Do you have SIP connections on the same network interface, and are those
> working as normal?
> Antony.
1- No changes to device names.  eth0 is the main link to the network, 
eth1 (also internal) goes to a SIP provider and eth2 (the USB adapter) 
goes to another SIP provider.  All IAX trunks use eth0

2- ifconfig gives the proper IP and netmask for all interfaces

3- We do not specify bindaddr or bindport in the config file as the 
default is to bind to

4- We had to make new SIP trunks to replace the IAX2 trunks to all 
servers.  The SIP trunk is working with no problems.  Except for two SIP 
links to PSTN all internal extensions use the same network interface.

Telecomunicaciones Abiertas de México S.A. de C.V.
Carlos Chávez
+52 (55)8116-9161

More information about the asterisk-users mailing list