[asterisk-users] Pickup(), PickupChan()... PickupQueue()?

Niccolò Belli darkbasic at linuxsystems.it
Sun Oct 30 13:17:00 CDT 2016

I'm currently using Pickup() to pickup calls from queues, but this is VERY 
annoying because often users from different queues dialed the very same 
extension (for example they pressed '1' to reach something but in different 
submenus). Other times they didn't dial anything but they end up in the 
very same queue, so the extension to pickup is the number they called.
So every time I want to send users to a queue I have to put a Goto() before 
the Queue() app because I need to uniquely identify the extension (for 
example Goto(QueueName,1)).
This is annoying. Really annoying. It also makes the dialplan hard to read.
Since we also have PickupChan() is to would be nice to have PickupQueue() 
too. That way we shouldn't care about the extension, we should simply write 
PickupQueue(QueueName). Simple and clear, the dialplan thanks.

Best regards,
Niccolo' Belli

More information about the asterisk-users mailing list