[asterisk-users] Regression in 13.13.0-RC1

Guido Falsi mad at madpilot.net
Tue Nov 22 04:57:57 CST 2016

On 11/22/16 11:46, Joshua Colp wrote:
> On Tue, Nov 22, 2016, at 05:55 AM, Guido Falsi wrote:
>> In my setup, which is FreeBSD, using pjsip 2.5.5 as sip backend I am
>> observing a regression when testing the latest Release Candidate.
>> Any calls get refused and the following error shown on console:
>> [Nov 22 10:49:26] WARNING[101105]: res_rtp_asterisk.c:2400 int
>> create_new_socket(const char *, int): Unable to allocate RTP socket:
>> Protocol not supported
>> [Nov 22 10:49:26] WARNING[101105]: res_rtp_asterisk.c:2665 int
>> ast_rtp_new(struct ast_rtp_instance *, struct ast_sched_context *,
>> struct ast_sockaddr *, void *): Failed to create a new socket for RTP
>> instance '0x805647c30'
>> [Nov 22 10:49:26] ERROR[101105]: res_pjsip_sdp_rtp.c:184 int
>> create_rtp(struct ast_sip_session *, struct ast_sip_session_media *):
>> Unable to create RTP instance using RTP engine 'asterisk'
>> Please note that with asterisk 13.12.2 everything works fine. No other
>> change was made to the system.
>> Is this a known issue being worked on? Should I file a bug report?
> Everything is tracked on JIRA, and there's no current issue open for
> this so it's not being worked on. You would need to file an issue[1].

I will for sure.

In the while I've been investigating the issue and found out the error
happens because asterisk is trying to open an INET6 socket, but the
machine has no inet6 configured.

This commit seems related to what I'm seeing:


I'll put this information in the bug report, obviously.

>> I am the maintainer of the FreeBSD Asterisk port in the ports tree, and
>> I routinely test Release candidates when available to speed up updating
>> the port. So I'm especially interested in this issue being investigated,
>> otherwise I'll have to hold up updating the FreeBSD Asterisk port.
> FreeBSD isn't really a platform we support or actively target, so we'll
> see what we can do and if it should hold up the release.

I see, but asterisk usually works quite fine in FreeBSD, so I'll try to
keep it working.

BTW my findings don't indicate anything FreeBSD specific in this issue
at present, I suspect that a linux machine with a similar configuration
would experience the same problem.

Guido Falsi <mad at madpilot.net>

More information about the asterisk-users mailing list