[asterisk-users] is there some blocking in 11.21.0

Tony Mountifield tony at softins.co.uk
Thu Jan 21 09:07:44 CST 2016

In article <CABr8-B7F1MVwPiL5Da8=qZGukU8EhvZX6ZyW5bZS55_JnB93_Q at mail.gmail.com>,
Jerry Geis <geisj at pagestation.com> wrote:
> >>On Thursday 21 Jan 2016, Jerry Geis wrote:
> >>* I am using the AMI interface to start calls.
> *>> >>* At one point I have a 10 second delay "Wait(10)" in the dialplan...
> *>>* During this time it "seems" that if I then connect with the manager
> *>>* interface
> *>>* and place a call that nothing happens till the 10 seconds is done...
> *>> >>* I am requesting Async yes...
> *>>* manager_str Action: Originate[CR ][LF ]Async: Yes[CR ][LF ]Channel:
> *>>* SIP/430[CR ][LF] (this is the first part of the AMI string)
> *>> >>* How can I get past that... I want the other call to happen right away.
> *
> >Use Priority: to begin at the dialplan step after the Wait() command.
> Thanks AJS - Sorry, I was not clear enough.
> Its not the command right after the Wait(10) that is being delayed....
> I have another process that issuing the commands to the AMI.
> Its basically like this:
> AGI( run to bring items into conference SIP/100 & SIP/101 lets say)
> Wait(10)
> ConfBridge(to take this user into above conference)
> But the SIP/100 and SIP/101 calls do not take place until a second delay.
> Why are the SIP/100&SIP/101 calls delayed during the Wait(10) ?

Are you saying that this worked in earlier versions but you started to
get the delay when you updated to 11.21.0? Or just that you happened to
be using 11.21.0 the first time you tried this scenario?

Tony Mountifield
Work: tony at softins.co.uk - http://www.softins.co.uk
Play: tony at mountifield.org - http://tony.mountifield.org

More information about the asterisk-users mailing list