[asterisk-users] PJSIP TLS sometimes RTP, sometimes no RTP

Chirag Desai djchillerz at gmail.com
Wed Jan 20 14:46:02 CST 2016

Hi George,

I tried the nightly build and also Bria. I can replicate the same issue on both.

This morning I made many successful calls in succession. This evening
it was intermittent again.

Could it be the mobile network is blocking the RTP but it seems odd it
works sometimes and not others.

That said I have another setup with Kamailio which talks to the same
asterisk via pjsip. I get audio on this account every single time when
using mobile networks. It's very strange. It seems like PJSIP simply
doesn't set up the RTP when I connect to the asterisk directly.

Any other suggestions?

On Tue, Jan 19, 2016 at 5:05 PM, *George Joseph* <george.joseph at
fairview5.com> wrote:

> With the exception of media_encryption_optimistic=yes and ice_support  =
> no, my setup looks like yours and I'm not having any problems with
> CSipSimple, even with SRTP mode = mandatory.  I assume your server has a
> public IP address and there's no NAT involved on the server side?  Oddly
> enough, I have ICE and Aggressive ICE turned on in CSipSimple.
> CSipSimple in the Play store is a little stale.  Have you tried the
> "nightly" version?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-users/attachments/20160120/9c595a4c/attachment.html>

More information about the asterisk-users mailing list