[asterisk-users] Upgraded to 13 and now "Mailbox" is empty in sip show peers

Matthew Jordan mjordan at digium.com
Wed Nov 19 08:12:19 CST 2014

On Tue, Nov 18, 2014 at 6:36 PM, Jayson Baker <jayson at spectrasurf.com> wrote:
> Using realtime for SIP.
> Using standard DB schema.
> Tried mailbox as varchar(50) and bigint(10)
> "sip show peer XXX" shows "Mailbox: " (empty)
> So MWI isn't working

The "mailbox" column in a database schema should be varchar, and big
enough to hold a fully qualified mailbox name.

> This happened before when we tried to go up to 1.8, so we stayed at 1.4
> We're forced to go to 13 now.  Obviously a lack of MWI is a big issue for
> 500 units.
> Any idea why we're not getting it?
> We're tried filling it into MySQL like "xxx at context" or just "xxx"
> No matter what, it doesn't work.

Per the CHANGES notes, you must now fully qualify a mailbox:

 * Mailboxes defined by app_voicemail MUST be referenced by the rest of the
   system as mailbox at context.  The rest of the system cannot add @default
   to mailbox identifiers for app_voicemail that do not specify a context
   any longer.  It is a mailbox identifier format that should only be
   interpreted by app_voicemail.

So, if using app_voicemail, your mailboxes should always be
'xxx at vm_context' where appropriate. I don't think this is your problem

> Or maybe some how to debug/diagnose this?

Are the rest of the fields in your peers being extracted correctly?
Can you provide the output from your database for one of your peers?
Which realtime backend are you using?

Matthew Jordan
Digium, Inc. | Engineering Manager
445 Jan Davis Drive NW - Huntsville, AL 35806 - USA
Check us out at: http://digium.com & http://asterisk.org

More information about the asterisk-users mailing list