[asterisk-users] sslv3 alert handshake failure error

Atul Thosar atulthosar at gmail.com
Sun Nov 2 10:35:38 CST 2014

Hi All,
I am using "asterisk-11.12.0" version and I am trying to setup secure call
(TLS + SRTP) between two extensions and while making a call, I got
following error

*CLI>   == Using SIP RTP CoS mark 5
    -- Executing [6004 at from-office:1] Dial("SIP/6003-00000000",
"SIP/6004,20") in new stack
  == Using SIP RTP CoS mark 5
    -- Called SIP/6004
SSL certificate ok
  == Problem setting up ssl connection: error:14094410:SSL
routines:SSL3_READ_BYTES:sslv3 alert handshake failure
[Nov  2 21:20:05] WARNING[3571]: tcptls.c:673 handle_tcptls_connection:
FILE * open failed!

I followed instruction given in "
https://wiki.asterisk.org/wiki/display/AST/Secure+Calling+Tutorial", but no
I googled around the issue and found solution mentioned by Patrick (

Did anyone has tried this solution and found it is working? I tried to
create certificates with keyUsage/extendedKeyUsage, but it is not working.

I have one more query - When the SIP user agents are able to register
successfully with TLS, why more handshake is required while making a call?
Can't Asterisk use existing TLS connection with Leg B to forward INVITE
request? Could anyone please educate me on the same? I am little confused

​​Thanks in advance.
Atul Thosar
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-users/attachments/20141102/eb5aa2b1/attachment.html>

More information about the asterisk-users mailing list