[asterisk-users] Multicast RTP

Eric Wieling EWieling at nyigc.com
Thu May 8 15:17:16 CDT 2014

I believe Polycom phones support Multicast for paging and intercom without any Asterisk involvement.  Check the Admin Guide.

-----Original Message-----
From: asterisk-users-bounces at lists.digium.com [mailto:asterisk-users-bounces at lists.digium.com] On Behalf Of Josh Metzger
Sent: Thursday, May 08, 2014 4:13 PM
To: Asterisk Users Mailing List - Non-Commercial Discussion
Subject: Re: [asterisk-users] Multicast RTP

On Thu, May 8, 2014 at 10:22 AM, Kevin Larsen <kevin.larsen at pioneerballoon.com> wrote:

	> From: Josh Metzger <joshdmetzger at gmail.com> 

	> I'm currently working with Asterisk 11.8.1 trying to get Multicast 
	> RTP working (it's not) with some Polycom phones, and I'm really 
	> trying to determine if Asterisk or the phones are the issue.  I 
	> THINK it's Asterisk...
	> In extensions.conf I have a simple: "Page(MulticastRTP/basic/
	> x.x.x.x:xxxx) line, and when I dial that extension I get:
	>    -- Called MulticastRTP/basic/x.x.x.x:
	> 5555                                                                               
	>     -- MulticastRTP/0x7f8b4000f898 answered SIP/XXXXXXX-0000004c 
	> After connecting and hearing the "beep" the line stays open and I 
	> can talk and press buttons and so on, but the phones aren't getting 
	> anything.  I ran "rtp set debug on" and if I call extension to 
	> extension I see all of the "got RTP packet from" and "Sent RTP 
	> packet to" messages as expected, but doing the same thing when 
	> calling my Multicast Page extension only shows me "Got RTP packet 
	> from" messages.  Shouldn't I see the "Sent RTP packet to" messages 
	> with the Multicast address/port displayed?  I've also run a 
	> wireshark capture and all I see is the RTP stream from my phone to 
	> the server - nothing going back out.  What am I missing, here?
	See here: http://community.polycom.com/t5/VoIP/Asterisk-1-8-Multicast/td-p/10918 <http://community.polycom.com/t5/VoIP/Asterisk-1-8-Multicast/td-p/10918>  
	It refers to Asterisk 1.8, but the situation remains the same. Polycom phones, to my knowledge, do not work with any kind of multicast stream that is supported by Asterisk. They need the whole SIP signalling to set up the call. We use Polycom phones and the way we worked it out was to build a dialgroup with all the active phones and then page that dialgroup. 
	Here is the code I am using: 
	exten => s,1,SIPAddHeader(Alert-Info: Ring Answer) 
	  same => n,Gosub(sub_active_phones,${EXTEN},1(page)) 
	  same => n,Set(CALLERID(name)=Emergency Page) 
	  same => n,Page(${DIALGROUP(page)},is) 
	  same => n,Hangup() 
	The sub-routine I call goes through all our extensions and builds a dialgroup of only those that are currently reachable and not on a call. 
	On the Polycom side, they are set to auto answer when they see the Alert-Info: Ring Answer header. Yes, this does mean that I am generating one call for every phone I am paging and yes it is less ideal (by far) than using multicast rtp. We did tests to determine that in an emergency it put an acceptable load on Asterisk and that it wouldn't cause it all to crash and burn. 

Interesting.  I thought the latest Polycom software supported multicast, but that Polycom forum link says otherwise.  What DOES work is using the built-in paging feature, so maybe the solution, in this case, is to do it without Asterisk at all.  We currently have a setup similar to what you have which works, but isn't as optimal as doing it multicast (lots of phones leads to the message getting chopped for some phones).  In any case, thanks for the info!

More information about the asterisk-users mailing list