[asterisk-users] Reload problems with 1.8.27 and 11.9.0 - Someone else ?

Administrator TOOTAI admin at tootai.net
Wed May 7 02:19:02 CDT 2014

Le 07/05/2014 00:57, Rusty Newton a écrit :
> On Thu, May 1, 2014 at 11:08 AM, Administrator TOOTAI <admin at tootai.net> wrote:
> <snip>
>> As explained in one on my previous message, it's a bug, easily reproducible:
>> take a queues.conf (or sip.conf or iax.conf or voicemail.conf or ...) like
>> this (what is important is the #include):
> <snip>
>> NOTICE[3346]: app_queue.c:6811 reload_queue_rules: queuerules.conf has not
>> changed since it was last loaded. Not taking any action.
>> despite the fact that modification was done in a .conf file. I took this
>> example as with module reload app_queue the above message appears. For sip,
>> iax, voicemail, aso there is no message, just "SIP reload" or ...
>> To make asterisk take the modification in account, you have to open
>> /etc/asterisk/[sip|iax|voicemail|queue|..].conf and save it without making
>> any change. After this the command will be execute. It you run it a second
>> time in a raw, you will see that the false behavior appears again till you
>> again open/save the original file.
> Hi!


> I tried to reproduce using your description here and could not
> reproduce the issue.
> I tried with both sip.conf and queues.conf.
> Making a change in an included .conf file, but NOT the parent .conf
> file and then reloading that module from the CLI results in:
> centosclean*CLI> module reload app_queue.so
>      -- Reloading module 'app_queue.so' (True Call Queueing)
> [May  6 17:51:39] NOTICE[16211]: app_queue.c:7765 reload_queue_rules:
> queuerules.conf has not changed since it was last loaded. Not taking
> any action.
>    == Parsing '/etc/asterisk/queues.conf': Found
>    == Parsing '/etc/asterisk/queue_include_1.conf': Found
>    == Parsing '/tmp/queue_include_2.conf': Found
> I get the same behavior with sip.conf, it appears to work fine,
> whether I'm making only changes in the parent .conf or the included
> children. I even tried with two different included files in each
> sip.conf and queues.conf, one in /tmp and one in /etc/asterisk. Same
> working behavior.

Ok, let's explain our files conf.

/etc/asterisk/<all asterisk original conf files>

conf files>.conf

The local directory and all his subdirectories are owned by a normal 
user with 755 rights

Configuration set sample with sip.conf:

In /etc/asterisk/sip.conf, we have #include 
local/additionnal_sip-general.conf in one place in the file and at the 
end of the file we have #include local/sip.d/*.conf

This setup is the same since ages and was working well. Remember that 
switching back to previous version or 11.8.1 make this setup 
working again.

We have this proplem on all servers we upgraded to last asterisk version

> I used SVN-branch-11-r413305, so you might want to test there.
> However I'm still confused as to how you are seeing the behavior you
> are seeing.

Servers are in production.

Thanks for your support


More information about the asterisk-users mailing list