[asterisk-users] IAX2 bridge failing

Michelle Dupuis mdupuis at ocg.ca
Fri Dec 13 10:46:10 CST 2013

I tried transfer=no, transfer=yer, and transfer=mediaonly (with a "reload" inbetween)....same result

I agree it sounds like something either end is using the wrong IP/port address somewhere in the call (yet signalling works fine).

Anything else to suggest?  I was hoping for an externalip type setting but not in iax2 (at least not in 1.4.x.x)
From: asterisk-users-bounces at lists.digium.com [asterisk-users-bounces at lists.digium.com] On Behalf Of Joshua Colp [jcolp at digium.com]
Sent: Friday, December 13, 2013 11:44 AM
To: Asterisk Users List
Subject: Re: [asterisk-users] IAX2 bridge failing

Michelle Dupuis wrote:
> Some more details...I noticed that the call is bridged, and audio goes
> one way. However, the dial command still times out after 35 seconds
> (approx), and exists non-zero.
> While the channels are up, I did an core show channel xxx and found
> Blocking in:
> ast_waitfor_nandfds
> Is this a bug? Or something I can fix through config?


Set "transfer=no" under the entries in iax.conf for the
peers/users/friends/etc in question, reload, retry, and see if that
changes the behavior. If it does then something involved may not like
IAX2 native transfers.


Joshua Colp
Digium, Inc. | Senior Software Developer
445 Jan Davis Drive NW - Huntsville, AL 35806 - USA
Check us out at:  www.digium.com  & www.asterisk.org

-- Bandwidth and Colocation Provided by http://www.api-digital.com --
New to Asterisk? Join us for a live introductory webinar every Thurs:

asterisk-users mailing list
To UNSUBSCRIBE or update options visit:

More information about the asterisk-users mailing list