[asterisk-users] Line noise/hiss on Openvox A400P card on FXO

Sebastian Arcus shop at open-t.co.uk
Thu Mar 1 04:05:17 CST 2012

I have a server with an OpenVox A400P card with 2 FXO modules on it. The 
internal extensions are SIP Grandstream phones. When making or receiving 
external calls through PSTN, there is an interrupted hissing like high 
pitch noise - which might go away for few seconds then start again.

1. The noise is not present when calling in between internal extensions 
(SIP only).
2. The noise is the same on both PSTN lines.
3. The noise is NOT present when I tried two different phones directly 
in the PSTN line(s) (a Philips DECT phone and a BT Converse phone)

Is the noise interference actually on the line, which the phones filter 
out because of their better electronic design (then the OpenVox card) - 
or is it generated somewhere in the server or on the OpenVox card?

I have tried:
1. Checking the interrupts and making sure the OpenVox card has its own IRQ.
2. Moving the card around on different PCI slots.
3. Changing the second network card with a different model (the first 
one is integrated in the motherboard).
4. Changing the motherboard, CPU and RAM (one motherboard AMD with Sis 
chipset, the other one Intel).
5. Placing ferrite cores on the phone cables.
6. Checking to see if the OpenVox card gets 1000 interrupts per second 
and it does.
7. Upgrading the kernel from 2.6.29 to 2.6.37
8. Ran FXO tune and made sure it starts with DAHDI
9. Disabled and enable software echo cancellation - it makes no difference.

The server is virtually under no load during the tests. It does have IDE 
hard-drives (which apparently can cause problems) - but there is not 
much I can do about that.

I also have a Sangoma USB FXO adapter - which I'm about to install and 
configure to see if it makes a difference.

I would really like to figure out where is the noise coming from - as 
I'm going a bit in circles. If I can find out for sure that the OpenVox 
card is either broken or low quality - I'll just have to replace it. But 
I can't even figure that out for sure.

The specs are:

CPU: Celeron 2.4GHz
Asterisk 10.1.2
Dahdi 2.6.0
Hard-drives: IDE
OpenVox A400P analog card

Many thanks for any advice.

More information about the asterisk-users mailing list