[asterisk-users] Asterisk SIP Realtime Architecture Issue/Bug.

Bryant Zimmerman BryantZ at zktech.com
Fri Feb 10 06:21:01 CST 2012

I see this on some peers every time I do a sip reload and I am not using 
real-time. I use qualify and every time a sip reload occurs the device goes 
unreachable. I have shortend the  register time to 5 min so the device 
comes back with-in about two min but it is very annonying to me and my 
user.  I have tracked my issue back to cusomters using netgear routers. If 
they replace the device the issue goes away. On netgear routers we have 
found we have to shut of SIP AGL to get them to register right but this 
quark won't go away.  Maybe your issue is endpoint releated as well?


 From: "DHAVAL INDRODIYA" <dhaval.it01034 at gmail.com>
Sent: Friday, February 10, 2012 12:22 AM
To: "Asterisk Users Mailing List - Non-Commercial Discussion" 
<asterisk-users at lists.digium.com>
Subject: Re: [asterisk-users] Asterisk SIP Realtime Architecture 

nobody facing any issue with this or nobody using real time architecture

On Thu, Feb 9, 2012 at 10:54 AM, DHAVAL INDRODIYA 
<dhaval.it01034 at gmail.com> wrote:
Hi Group.

I am facing an issue with Peer registration in my asterisk server .

I am using asterisk version and using SIP real-time 
architecture.when i am doing registration it registered fine on asterisk 
as peer is available in Database.

But now i am doing 'sip reload' or 'reload' due to some reason my peer 
registration is going out and i cannot able to call that peer even though 
in SIP client it shows me 'registered'.

Can any body elaborate on this issue which settings i need to put in 

I also tried to follow this patch 
https://issues.asterisk.org/view.php?id=14196 But it allready applied in 
code base so why it wont work?

Here is my sip.conf settings.

context=from-internal        ; Default context for incoming cal
callcounter = yes
bindport=5060            ; UDP Port to bind to (SIP standard port is 5060)
srvlookup=yes            ; Enable DNS SRV lookups on outbound calls
pedantic=yes            ; Enable slow, pedantic checking for Pingtel
tos=184            ; Set IP QoS to either a keyword or numeric val
tos_sip=cs3                    ; Sets TOS for SIP packets.
tos_audio=ef                   ; Sets TOS for RTP audio packets. 
tos=lowdelay            ; lowdelay,throughput,reliability,mincost,none
maxexpiry=3600            ; Max length of incoming registration we allow
defaultexpiry=120        ; Default length of incoming/outoing registration
disallow=all            ; First disallow all codecs
allow=ulaw            ; Allow codecs in order of preference
language=en                   ; Default language setting for all 
rtpholdtimeout=300        ; Terminate call if 300 seconds of no RTP 
useragent=dhaval              ; Allows you to change the user agent string
dtmfmode = rfc2833        ; Set default dtmfmode for sending DTMF. Default: 

And here is DB fields snapshots.

               id: 1
             name: 201
             port: 53624
       regseconds: 1328716180
      defaultuser: 201
      fullcontact: NULL
        regserver: dhaval
        useragent: CSipSimple r1133 / b
           lastms: 554
             host: dynamic
             type: friend
          context: from-internal
           permit: NULL
             deny: NULL
           secret: 201
        md5secret: NULL
     remotesecret: NULL
        transport: NULL
         dtmfmode: NULL
      directmedia: yes
              nat: NULL
            allow: ulaw
         disallow: g729
         insecure: invite
         callerid: NULL
rfc2833compensate: NULL
          mailbox: NULL
   session-timers: NULL
  session-expires: NULL
    session-minse: NULL
session-refresher: NULL

Kindly help me to resolve this.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-users/attachments/20120210/f4adac49/attachment.htm>

More information about the asterisk-users mailing list