[asterisk-users] Cisco AS5300

Mark Rounds markr at 1340media.com
Thu Jan 4 19:37:27 MST 2007


I have a similar configuration.  Here is my cisco(Edited for security of
course!):

resource-pool disable
no aaa new-model
!
resource policy
!
spe default-firmware spe-firmware-1
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
!
!
isdn switch-type primary-ni
!
voice rtp send-recv
!
voice service voip
 fax protocol none
 modem passthrough nse codec g711ulaw
 sip
!
!
voice class codec 1
 codec preference 1 g729r8
 codec preference 14 g711ulaw
!
!
!
!
!
!
!
!
!
!
!
!
!
controller T1 3/0
 framing esf
 linecode b8zs
 cablelength short 133
 pri-group timeslots 1-24
!
controller T1 3/1
 framing esf
 linecode b8zs
 cablelength short 133
 pri-group timeslots 1-24
!
controller T1 3/2
 framing esf
 linecode b8zs
 cablelength short 133
 pri-group timeslots 1-24
!
controller T1 3/3
 framing esf
 linecode b8zs
 cablelength short 133
 pri-group timeslots 1-24
!
translation-rule 1
 Rule 0 ^0 0 unknown national
 Rule 1 ^1 1 unknown national
 Rule 2 ^2 2 unknown national
 Rule 3 ^3 3 unknown national
 Rule 4 ^4 4 unknown national
 Rule 5 ^5 5 unknown national
 Rule 6 ^6 6 unknown national
 Rule 7 ^7 7 unknown national
 Rule 8 ^8 8 unknown national
 Rule 9 ^9 9 unknown national
!
!
translation-rule 2
 Rule 0 ^011 011 unknown international
!
!
!
interface FastEthernet0/0
xxxxx
!
interface FastEthernet0/1
xxxxx
!
interface Serial0/0
 no ip address
 shutdown
 clockrate 2000000
!
interface Serial0/1
 no ip address
 shutdown
 clockrate 2000000
!
interface Serial3/0:23
 no ip address
 isdn switch-type primary-ni
 isdn incoming-voice modem
 isdn negotiate-bchan
 no cdp enable
!
interface Serial3/1:23
 no ip address
 isdn switch-type primary-ni
 isdn incoming-voice modem
 isdn negotiate-bchan
 no cdp enable
!
interface Serial3/2:23
 no ip address
 isdn switch-type primary-ni
 isdn incoming-voice modem
 isdn negotiate-bchan
 no cdp enable
!
interface Serial3/3:23
 no ip address
 isdn switch-type primary-ni
 isdn incoming-voice modem
 isdn negotiate-bchan
 no cdp enable
!
interface Async1
 no ip address
!
interface Group-Async0
 no ip address
 group-range 1/00 1/107
!
ip default-gateway xxxx
ip classless
ip route 0.0.0.0 0.0.0.0 xxxxx
!
!
!
!
!
!
control-plane
!
!
!
voice-port 3/0:D
!
voice-port 3/1:D
!
voice-port 3/2:D
!
voice-port 3/3:D
!
!
!
dial-peer voice 11 voip
 preference 1
 destination-pattern ..........
 progress_ind setup enable 3
 progress_ind progress enable 8
 modem passthrough nse codec g711ulaw
 voice-class codec 1
 session protocol sipv2
 session target ipv4:xxxxx
 incoming called-number .T
 dtmf-relay rtp-nte
 fax rate disable
 no vad
!
dial-peer voice 1 pots
 destination-pattern .T
 translate-outgoing calling 1
 translate-outgoing called 1
 no digit-strip
 direct-inward-dial
 port 3/0:D
!
dial-peer voice 2 pots
 destination-pattern .T
 translate-outgoing calling 1
 translate-outgoing called 1
 no digit-strip
 direct-inward-dial
 port 3/1:D
!
dial-peer voice 3 pots
 destination-pattern 011
 translate-outgoing called 2
 no digit-strip
 direct-inward-dial
 port 3/1:D
!
dial-peer voice 4 pots
 destination-pattern .T
 translate-outgoing calling 1
 translate-outgoing called 1
 no digit-strip
 direct-inward-dial
 port 3/2:D
!
dial-peer voice 5 pots
 destination-pattern 011
 translate-outgoing called 2
 no digit-strip
 direct-inward-dial
 port 3/2:D
!
dial-peer voice 6 pots
 destination-pattern .T
 translate-outgoing calling 1
 translate-outgoing called 1
 no digit-strip
 direct-inward-dial
 port 3/3:D
!
dial-peer voice 7 pots
 destination-pattern 011
 translate-outgoing called 2
 no digit-strip
 direct-inward-dial
 port 3/3:D
!
!
sip-ua
!
ss7 mtp2-variant Bellcore 0
ss7 mtp2-variant Bellcore 1
ss7 mtp2-variant Bellcore 2
ss7 mtp2-variant Bellcore 3
!
line con 0
line aux 0
line vty 0 4
xxxxx
login
line 1/00 1/107
 no flush-at-activation
 modem InOut
!
End



I noticed that your config refered to E1.  Might need to tweak the filters
and such for your config as I'm sure if your using E1 your probably in
Europe?  Not to mention the T1 Controllers are E1 in your case, with
different line coding options, et al. 

I've found no trouble with IOS 12.3(14)T4.  Others may work, but you can't
beat the stability of this software in my opinion.

Might need to tweak it if you're pushing for T.38 for your faxing.  

Also, with this config, it gets a little hairy with the dial peers if your
asterisk box denies any calls from the PSTN.  Luckly in my scenario, I
controll the PSTN Switch, Cisco AS5350, as well as the softswitch.  As far
as the determining which way to point it.  Well, the PRI sends my calls over
the voip peer with the "preference 1", and the "incoming called-number .T"
along with the "preference 1" in the voip peer lends to it going out the PRI
lines instead because it won't "wrap around" back to the VoIP Peer it came
from. I have had the occasional failure in the VoIP Switch if I didn't have
the number accepted by The VoIP Peer, it bounced back over the PRI.  My
Sanity Check is on the PSTN Switch in that case, but you may not have a PRI
Provider that is as accomidating as myself.


Also, if you append a "code" like "9999" infront of the destination number,
like this



dial-peer voice 1 pots
 destination-pattern 9999.T       <--- 9999 is the code for this pri
 translate-outgoing calling 1
 translate-outgoing called 1
 digit-strip				<---- Make sure the 9999 gets
striped and not sent to the PSTN
 direct-inward-dial
 port 3/0:D

Then that should provide a pretty safe solution.  To add this "code", you
would probably add it in your dialplan like 9999{$EXTEN} or something else
like that.

I hope this helps.

Mark


-----Original Message-----
From: asterisk-users-bounces at lists.digium.com
[mailto:asterisk-users-bounces at lists.digium.com] On Behalf Of Andrew
Pogrebennyk
Sent: Thursday, January 04, 2007 5:31 PM
To: Asterisk Users Mailing List - Non-Commercial Discussion
Subject: Re: [asterisk-users] Cisco AS5300


Hello Yusuf

yusuf wrote:
> Hi all,
> 
> I realize this is OT.
> 
> I just got a Cisco AS5300, and I need to configure it like such:
> 
> 
> Asterisk -----(H323/SIP)------> Cisco ----- (E1/PRI)------->Telco
> 
> So calls originate from the Asterisk side (registered users on SIP or
> just ZAP phones), and they go out H323 or SIP to Cisco, where they go 
> out PRI.
> 
> I have the Asterisk side sorted :) (either H323 or SIP), I need help 
> in
> the Cisco side. Can anyone give me a brief HOW-TO or tutorial on getting 
> this (either SIP or H323) done on the Cisco side.

The link with sample Cisco config Hoah has sent is fine. It's well 
commented etc, but... I do not recommend you to copy it entirely :)

 > [...skipped...]
> How do I specify that H323 or SIP must be for incoming calls, and
> outgoing must go out on the E1.
> 
> Cisco is running IOS 12.1.5-12.2.13a
> I realize this is alot of questions, so please bear with me :)

You seem to need a clear-cut explanation of dial-peer matching process 
like http://www.cisco.com/warp/public/788/voip/in_dial_peer_match.html 
or more complete guides: 
http://www.cisco.com/univercd/cc/td/doc/product/software/ios123/123cgcr/vvfa
x_c/int_c/dpeer_c/dp_confg.htm 
and 
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fvvf
ax_c/vvfpeers.htm
I think I can help you deal with Cisco side once you have drafted a 
clear setup.

-- 
Sincerely,
Andrew Pogrebennyk _______________________________________________
--Bandwidth and Colocation provided by Easynews.com --

asterisk-users mailing list
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-users


-- 
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.5.432 / Virus Database: 268.16.4/615 - Release Date: 1/3/2007
1:34 PM
 

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.5.432 / Virus Database: 268.16.4/615 - Release Date: 1/3/2007
1:34 PM
 



More information about the asterisk-users mailing list