[asterisk-users] One way audio problem on gateway to PSTN after some time, no NAT involved

Giorgio Incantalupo gincantalupo at fgasoftware.com
Thu Sep 14 02:11:50 MST 2006

Hi Kai,
we had a similar problem with a PBX which had PSTN lines and SIP phones: 
sometimes some phones had one way calls...the caller couldn't hear. We 
hadn't tried to restart but we reduced the number of RTP ports (rtp.conf 
if memory helps!) to a range of 200 (it depends from the number of 
simultaneous calls you have).
That seemed to work!
Hope it may help!

Giorgio Incantalupo

Kai Militzer wrote:
> Hello everyone,
> since some weeks I experience strange problems on my gateways to the
> PSTN. The gateways use chan_ss7 and SIP. My setup is roughly like that
> SER --> Asterisk A --> Asterisk B (chan_ss7) --> PSTN
> What happens is, that after a while (uptime was a least two days) the
> gateway starts to not transmit audio to the PSTN on outgoing calls, but
> the caller can still hear the called party. There is no NAT involved and
> firewall rules allow the RTP ports defined in rtp.conf on both asterisk
> (A and B) machines. The SIP packages look good, no errors messages from
> asterisk or anything else, so I have really no idea what causes it and I
> cannot reproduce it except by waiting till it happens again. :(
> Now the strange thing is, that if I restart the asterisk all works fine
> again. A reload does not help, only a restart. Until now I came across
> this phenomenon two times on different machines and it all started about
> three weeks ago. Before that I ran asterisk 1.2.10 on the machines and
> then updated to 1.2.11. I looked through the Changelog but coulnd't find
> anything that seems related, but I guess it's a bug that was introduced
> somewhere between 1.2.10 and 1.2.11 ...
> Does anyone else have similar problems?
> Regards,
> Kai

More information about the asterisk-users mailing list