[asterisk-users] OT, Definity G3 Problems with Asterisk (Any Avaya

Steve Totaro stotaro at asteriskhelpdesk.com
Wed Sep 13 12:45:50 MST 2006

BJ Weschke wrote:
> On 9/13/06, Steve Totaro <stotaro at asteriskhelpdesk.com> wrote:
>> BJ Weschke wrote:
>> > On 9/13/06, Steve Totaro <stotaro at asteriskhelpdesk.com> wrote:
>> >> Doug Lytle wrote:
>> >> > Steve Totaro wrote:
>> >> >> I am trying to connect a Definity G3 to an asterisk system. I 
>> had it
>> >> >> working OK with the exception of the caller ID on the Definity
>> >> >> handsets just
>> >> >
>> >> > He wants to know if your Definity is an S, SI or an R?
>> >> >
>> >> > Doug
>> >> >
>> >> I am not sure, it is a refrigerator sized unit with three 
>> cabinets. The
>> >> manual was printed in 1988 and is ATT&T Definity Communications 
>> System
>> >> Generic1 and Generic3.
>> >>
>> >> If you need more, I can go to the remote system and provide more
>> >> details.
>> >>
>> >> I REALLY appreciate you helping on this.
>> >>
>> >
>> > Sounds like a G3R. How are you signaling between the two? PRI?
>> >
>> Yes. I have two ISDN communication processor links setup which I later
>> read on google was not supported. Now I cannot remove the new entry. I
>> just get "identifier not assigned"
> What you'll want to do in order to set this up, is build a trunk
> group in DSA that consists of the two T1's, and then you'll want to
> build a signaling group that uses "isdn" signaling and then (probably
> 3-4 pages over in DSA) you'll want to assign all the channels of those
> T1s as "members" of that signaling group.
> On the asterisk side you'll want to setup the trunks as pri_net.
> Put a T1 crossover cable in between, if there's no carrier loops
> involved, and then you're done.


Here is what I did.

I setup a ds1 with standard T1 pri settings and set to the network.

I setup a trunk-group with all the ports on that ds1, set it to isdn-pri 
and tie and set the signaling to the step below

I setup a signaling-group with the primary d-channel as the 24rth port 
on the ds1 using associated signaling

I setup a data-module

I setup communication-interface link

I setup communication-interface processor to isdn h priority

I went back to communication-interface link and enabled it.

Everything worked perfectly. The d channel came up and 23 b channels 
through the definity and the new ivr server. Calls in and out sounded 
great and no PRI errors whatsoever.

I repeated the same steps above with the same settings but obviously 
different boards and identifiers.

Now the D channel goes up and down on both links and the b channels 
never come up

I remove everything I just added (new trunk-group, signaling group)

I tried to remove the data-module but it errors saying I have to remove 
it from the communication-interface link

I tried to remove the data-module from the communication-interface link 
but that errors saying I have to remove the communication-interface 

I tried to blank out the second entry for the communication-interface 
processor and it errors saying “Identifier not Assigned”

I have busied out everything related to the board and data-module and 
also tried to change the second isdn value in communication-interface 
processor but once I get all the values filled in, I get the same error 
“Identifier not Assigned”

The original PRI still does not work. The D channel comes up and down 
and no B channels.


More information about the asterisk-users mailing list