[Asterisk-Users] Re: What failed here?

John Chambers jc at trillian.mit.edu
Tue Mar 30 09:56:04 MST 2004

Interalab Sales wrote:
> Could you have asterisk running and not allowing you to overwrite while 
> trying to install?  Do you have root rights to create files in the 
> asterisk folders?

Well, one of the first things I found was that nothing at all worked
unless I was root, so I've done the entire install as root.  There was
an asterisk running, so I killed its processes (lots of them), and
tried again.  I got the same errors.  I also noticed that there is
in fact an "asterisk" executable created, and it runs (for some value
of "runs").  The "asterisk -vvvv" command produces lots of output, and
of course I don't understand any of it, so I don't know whether it's
sane or not.

Another worrying thing that I've noticed:  The stuff at the start
of the make (that scrolls off the top too fast to read ;-) first does
a mkdep, and then these messages appear:

cli.c:31:19: build.h: No such file or directory
dlfcn.c:40:25: mach-o/dyld.h: No such file or directory
dlfcn.c:41:26: mach-o/nlist.h: No such file or directory
dlfcn.c:42:28: mach-o/getsect.h: No such file or directory

Sure enough, those files don't exist. Some time later, build.h does
appear, when the Makefile runs make_build.h.  It seems a bit odd that
the Makefile would attempt to use build.h before creating it.  This
looks like a sign of something wrong, but I can't tell what. Any
idea how to fix this?  Or is it actually a problem?

I don't seem to see those mach-o files anywhere.  There's also no
mach-o directory; it never appears anywhere in the build tree.

> John Chambers wrote:
>> After doing "cvs checkout -r v1-0_stable asterisk" and typing the
>> usual "make clean ; make install", I got these messages:
>> ...
>> make[1]: Entering directory `/usr/src/asterisk/codecs'
>> make -C gsm lib/libgsm.a
>> make[2]: Entering directory `/usr/src/asterisk/codecs/gsm'
>> /var/spool/asterisk   -o src/k6opt.o src/k6opt.s
>> make[2]: execvp: /var/spool/asterisk: Permission denied
>> make[2]: *** [src/k6opt.o] Error 127

More information about the asterisk-users mailing list