[Asterisk-Users] Hang-ups when using IAX

Hadar Pedhazur hadar at unorthodox.com
Fri Mar 12 16:12:43 MST 2004

Darrin, I had a similar (though not identical) problem. The solution 
in my case was to add "notransfer=yes" in the iax.conf context for the 
IAX softphone. It's possible that the hand off to attempt a native 
transfer for you is failing because one of the servers is behind a NAT 
router. Anyway, it's worth a quick test.

Darrin Johnson wrote:

> I have two Asterisk systems running in my environment.  In between the 
> two there is a router running NAT.  One server services extensions 90XX 
> and the other extensions 95XX.  Both boxes are running Red Hat 9 with 
> version 0.7.2 Asterisk.

> I am running IAX and registering an IAX softphone to each server – so 
> two IAX clients with one registered as a 90XX number to the 90XX server 
> and one registered to the 95XX server with a 95XX number.  A call is 
> initiated from the client registered to the 90XX server to the client 
> registered on the 95XX server.  The call is completed successfully but 
> then after about 30 seconds to a minute the initiating client complains 
> that the remote user (95XX client) hung-up.  The 95XX client has the 
> connection still open and live until the hang-up button is manually clicked.

> The debug in Asterisk shows that the 90XX server records a remote 
> hang-up, but the 95XX server does not record anything until the hang-up 
> button is pushed from the 95XX client.

> Does anyone have any ideas as to why I would be getting a hang-up after 
> about 30 seconds when using IAX in this type of scenario?  I have tried 
> multiple clients with the same result which is implying there must be a 
> problem server-to-server.

> Thanks much for your help!

> Darrin Johnson
> Systems Engineer
> IS Domain Inc.

More information about the asterisk-users mailing list