[Asterisk-Users] Record Application

Jason Boyd jason at silenttype.com
Tue Mar 2 11:08:48 MST 2004

Scott, reply is at the bottom.

> I ran into a small issue with the Record app.  If I specify a silence 
> detection period the application makes the recording and hangs 
> up,instead of continuing with the dial-plan as it should. Now if I
> dont specify a silence detection period an use only the # to end all 
> recording sessions then everything works great, I make the recording, 
> press # and the recording finishes and the system continues with the 
> dial plan.
> With silence:
> exten => 205,2,Record(/tmp/asterisk-recording:gsm|5)
> Without Silence:
> exten => 205,2,Record(/tmp/asterisk-recording:gsm)
> I also receive this error message when I have the silence specified.
> NOTICE[475151]: Unable to find a path from ULAW to UNKN
> WARNING[475151]: Unable to restore read format on
> 'IAX2[default at]/2'

I'm seeing similar behavior using the RECORD FILE command in AGI.  If a
silence timeout is specified, I get the same messages (replace 'ULAW'
with 'GSM') when the recording times out, whether the timeout is due to
maximum record time exceeded or the maximum silence exceeded.  If the
user ends the recording with # the errors do not occur, even when there
is a silence parameter.

I have only tried this over IAX (with no dummy timer), and I was just
settling down to install a SIP client to try when I read your message.

The good news for you is that when this happens in AGI it does not
appear to have any obvious adverse effects.  Asterisk spits back a
successful result string and continues with the script.


More information about the asterisk-users mailing list