[Asterisk-Users] AGI dtmf problems (with x-lite) (solved)

Raul Elizondo (wizardteam) rauleli at wizardteam.com
Sat Aug 28 03:39:33 MST 2004

Hi Steven,

>IT is interesting you are even that far along with your AGI application
>when you haven't even figured out your mail client.

Do you mean my email client? or my voicemail?  Voicemail is working fine on
digim extensions, i even changed the language to spanish (btw, there are lot
of mistakes in the manner to say numbers).  The problem comes when i try to
use an agi with a x-lite client (softphone), it works fine with dtmf over
voicemail and over menu selection, but it does not recognice dtmf for agi's.

>What was the connection to the message about voice recognition that you
>replied to?

I am not using voice recognition, i m trying to use dtmf recognition with
agi's, but somehow, asterisk does not listen the x-lite only with agi's.
The rest of the digium fxs extensions works fine with my agi.

>If you wish to be lazy, go ALL OUT, and learn that you can start a new
>message with a new thread by clicking on the address of the mailing list
>in the headers section. It will bring up a new message with no content
>in it. It is a lot easier than deleting all the text in the old message.


>BTW, did you ANSWER() the call before going to AGI?

Actually no, and that was my problem.  When i begun to work with agi in tcl,
i was figuring out how it works from a perl script and i got some problems,
then, i used Answer() first times, i thought it was the error, when i
debuged my script, it worked fine with out the Answer() for digium

Now is working after i added Answer() on the extensions.conf for that.
Thanks for the hint! ;)


More information about the asterisk-users mailing list