[asterisk-ss7] WG: Sifira chan_ss7 for * 1.4.4

Hoai-Anh Ngo-Vi hoaianh at gmx.de
Wed Oct 3 09:57:02 CDT 2007


I haven't tried that yet. I will try it tomorrow as soon as possible.

I think chan_ss7.so is loaded but not registered as a channel driver because
CLI commands like "ss7 linestat", "help ss7" work. As I started asterisk I
could see the signalling channel processing on the CLI.

I can get incoming calls from PSTN.

Do you know any trick that might help to explicitly register chan_ss7.so as
channel driver?

By the way, I have also tried with asterisk 1.4.2 and it works well both
ways. Are you aware of any change in the way to register a module as channel
driver for asterisk 1.4 newer than 1.4.2?  

Thank & Regards

-----Ursprüngliche Nachricht-----
Von: asterisk-ss7-bounces at lists.digium.com
[mailto:asterisk-ss7-bounces at lists.digium.com] Im Auftrag von Mitul Limbani
Gesendet: Mittwoch, 3. Oktober 2007 16:01
An: asterisk-ss7 at lists.digium.com
Betreff: Re: [asterisk-ss7] WG: Sifira chan_ss7 for * 1.4.4


It looks like your channel driver hasnt got registered within Asterisk.
what error you see when you give this command on CLI : load module 
chan_ss7.so ?

Thanks & Regards,
Mitul Limbani,
Founder & CEO,
Enterux Solutions,
The Enterprise Linux Company (TM),

Quoting Hoai-Anh Ngo-Vi <hoaianh at gmx.de>:

> Hi.
> I've patched chan_ss7 for use with * 1.4.4. For incoming calls it works
> but while trying to make an outbound call I get those WARNINGS
>  -- Executing [1000 at default:3] Dial("SIP/",
> "ss7/siuc/6974223663") in new stack
> [Oct  2 18:59:38] WARNING[2539]: channel.c:3099 ast_request: No channel
> registered for 'ss7'
> [Oct  2 18:59:38] WARNING[2539]: app_dial.c:1099 dial_exec_full: Unable to
> create channel of type 'ss7' (cause 66 - Channel not implemented)
> Any idea or solution?

--Bandwidth and Colocation Provided by http://www.api-digital.com--

asterisk-ss7 mailing list
To UNSUBSCRIBE or update options visit:

More information about the asterisk-ss7 mailing list