[asterisk-ss7] MTP2 CRC errors resulting in flapping link

Christopher Bergström cbergstrom at netsyncro.com
Thu Jul 6 08:02:38 MST 2006

Kai Militzer wrote:
> Hello everyone.
> Kai Militzer wrote:
>>> 2) replace entire server with something new that is known to work well,
>>> does not have shared interrupt issues like many Dells were reported to
>>> have and has PCI 2.2 slots
>> That would be an idea, but it involes a lot of work and downtime. 
>> This will only be my last resort.
> I replaced the Hardware. No help. That's what I asked on #asterisk in 
> IRC. maybe one of you can explain this:
> OK people, I need your thouhts. I have a TE205P card for use with 
> chan_ss7 in a Server with a P4 3GHz. Over the last few weeks the MTP2 
> CRC-Errors (MTP2 is one layer above the E1-Layer) with this increased 
> because the zaptel input and output buffers were full or empty or 
> both. This resulted in a complete disfunction of chan_ss7 (no ss7 
> links could be started). I then tested the card with a cross-cable and 
> zaptel -> No problem. Cross cable and chan_ss7 -> doesn't work. 
> Another server with a P4 1.8GHz-> same problem. And now the miracle. 
> Another server with a AMD XP 2000 -> it work's without errors with a 
> cross cable
> ... Any thoughts on that? The thing that bothers me is, that it worked 
> once and the CRC-errors increased over time. Otherwise I would have 
> blamed the P4
Not sure how much time I can spend on this away from my current 
projects.. However.. I've been rewriting larger sections of chan_ss7 to 
get it working for another client.. You tried to help me on IRC the 
other day and if you like.. I'll return the favour..

on freenode I'm codestr0m



More information about the asterisk-ss7 mailing list