[asterisk-dev] [Code Review] 4438: add auto-dtmf mode for pjsip

Matt Jordan reviewboard at asterisk.org
Wed Mar 11 17:04:57 CDT 2015


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviewboard.asterisk.org/r/4438/#review14646
-----------------------------------------------------------



/trunk/res/res_pjsip_sdp_rtp.c
<https://reviewboard.asterisk.org/r/4438/#comment25210>

    Put spaces around assignments:
    
    int dsp_features = 0;



/trunk/res/res_pjsip_sdp_rtp.c
<https://reviewboard.asterisk.org/r/4438/#comment25211>

    I'd remove this extra newline, as it doesn't really need to be here and the retrieval of the codecs logically belongs with the call to ast_rtp_codecs_payload_formats.



/trunk/res/res_pjsip_sdp_rtp.c
<https://reviewboard.asterisk.org/r/4438/#comment25212>

    Remove the extraneous whitespace



/trunk/res/res_pjsip_sdp_rtp.c
<https://reviewboard.asterisk.org/r/4438/#comment25213>

    Use spaces with your boolean operator:
    
    if ((session->endpoint->dtmf == AST_SIP_DTMF_AUTO) && ...



/trunk/res/res_pjsip_sdp_rtp.c
<https://reviewboard.asterisk.org/r/4438/#comment25215>

    For ease of readability, I'd write this conditional expression as:
    
    if ((session->endpoint->dtmf == AST_SIP_DTMF_AUTO)
        && (ast_rtp_instance_dtmf_mode_get(session_media->rtp) == AST_RTP_DTMF_MODE_RFC2833)
        && session->dsp) {
        ...
    }



/trunk/res/res_pjsip_sdp_rtp.c
<https://reviewboard.asterisk.org/r/4438/#comment25214>

    Again, spaces.
    
    (ast_rtp_instance_dtmf_mode_get(session_media->rtp) == AST_RTP_DTMF_MODE_RFC2833) && (session->sdp)
    
    



/trunk/res/res_pjsip_sdp_rtp.c
<https://reviewboard.asterisk.org/r/4438/#comment25216>

    Spaces around operators here as well.



/trunk/res/res_pjsip_sdp_rtp.c
<https://reviewboard.asterisk.org/r/4438/#comment25217>

    Remove the extraneous red space.



/trunk/res/res_pjsip_sdp_rtp.c
<https://reviewboard.asterisk.org/r/4438/#comment25218>

    Extraneous white space.


- Matt Jordan


On March 9, 2015, 9:12 a.m., yaron nahum wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviewboard.asterisk.org/r/4438/
> -----------------------------------------------------------
> 
> (Updated March 9, 2015, 9:12 a.m.)
> 
> 
> Review request for Asterisk Developers.
> 
> 
> Bugs: ASTERISK-24706
>     https://issues.asterisk.org/jira/browse/ASTERISK-24706
> 
> 
> Repository: Asterisk
> 
> 
> Description
> -------
> 
> add auto-dtmf mode for pjsip
> 
> 
> Diffs
> -----
> 
>   /trunk/res/res_pjsip_session.c 431537 
>   /trunk/res/res_pjsip_sdp_rtp.c 431537 
>   /trunk/res/res_pjsip/pjsip_configuration.c 431537 
>   /trunk/res/res_pjsip.c 431537 
>   /trunk/main/dsp.c 431537 
>   /trunk/include/asterisk/res_pjsip.h 431537 
>   /trunk/include/asterisk/dsp.h 431537 
>   /trunk/channels/chan_pjsip.c 431537 
> 
> Diff: https://reviewboard.asterisk.org/r/4438/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> yaron nahum
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-dev/attachments/20150311/04082fc5/attachment.html>


More information about the asterisk-dev mailing list