[asterisk-dev] [Code Review] 3649: Bridging: Allow channels to define additional bridging hooks

Mark Michelson reviewboard at asterisk.org
Tue Jun 24 15:41:30 CDT 2014


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviewboard.asterisk.org/r/3649/#review12297
-----------------------------------------------------------



trunk/include/asterisk/bridge_channel.h
<https://reviewboard.asterisk.org/r/3649/#comment22458>

    This is an improper use of the \retval doxygen command. The syntax is \retval <return> <description>. You've just given a description. You can either go with
    
    \retval non-NULL The features currently set for this channel
    
    of
    
    \return The features currently set for this channel
    
    I'm not sure how a \return and \retval get along with each other, but I suspect it's fine.



trunk/include/asterisk/bridge_channel.h
<https://reviewboard.asterisk.org/r/3649/#comment22459>

    I would consider changing the name of this function:
    
    1) It sounds like it operates on an ast_bridge_channel, rather than an ast_channel.
    
    2) The "ds" is an implementation detail that doesn't need to be exposed.



trunk/include/asterisk/bridge_channel.h
<https://reviewboard.asterisk.org/r/3649/#comment22460>

    Same naming comments for this function.



trunk/include/asterisk/bridge_channel.h
<https://reviewboard.asterisk.org/r/3649/#comment22461>

    And this one.



trunk/include/asterisk/bridge_features.h
<https://reviewboard.asterisk.org/r/3649/#comment22462>

    No need for this. A function with a void return obviously returns nothing :)



trunk/tests/test_channel_datastore_features.c
<https://reviewboard.asterisk.org/r/3649/#comment22468>

    Replace the many while (nanosleep...) loops in this file with a single function call that takes the number of seconds and nanoseconds to sleep.


- Mark Michelson


On June 24, 2014, 6:06 p.m., opticron wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviewboard.asterisk.org/r/3649/
> -----------------------------------------------------------
> 
> (Updated June 24, 2014, 6:06 p.m.)
> 
> 
> Review request for Asterisk Developers and rmudgett.
> 
> 
> Bugs: AFS-78
>     https://issues.asterisk.org/jira/browse/AFS-78
> 
> 
> Repository: Asterisk
> 
> 
> Description
> -------
> 
> This patch allows the current owner of a channel to define various feature hooks to be made available once the channel has entered a bridge.
> 
> Currently, it is only possible to attach these hooks by calling ast_bridge_join or as_bridge_impart directly.
> 
> 
> Diffs
> -----
> 
>   trunk/tests/test_channel_datastore_features.c PRE-CREATION 
>   trunk/main/bridge_channel.c 416731 
>   trunk/main/bridge.c 416736 
>   trunk/include/asterisk/bridge_features.h 416731 
>   trunk/include/asterisk/bridge_channel.h 416731 
> 
> Diff: https://reviewboard.asterisk.org/r/3649/diff/
> 
> 
> Testing
> -------
> 
> Ensured that DTMF hooks could be attached to the channel via this mechanism and that they became available and were executable once the channel entered a bridge via Dial().
> 
> 
> Thanks,
> 
> opticron
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-dev/attachments/20140624/ea406995/attachment-0001.html>


More information about the asterisk-dev mailing list