[Asterisk-Dev] Re:DMS-500 CID name not in CDR

JR Richardson jr.richardson at cox.net
Sat Jun 11 16:52:35 MST 2005

I just found out from my provider, they are running version 10 on there

Also, I've tried the Wait() statement with up to 4 seconds, no help.  I've
tried to directly capture SetCDRUserField(${CALLERIDNAME}), but the field
get populated with just the number, the name doesn't register.

Again, I can send debug and intense debug PRI messages if needed.

Any clue will help.



>NI2 Protocol, if that is what you mean, not sure what "code set" is.


>What code set is the 500 PRI configured for?


On Fri, 2005-06-10 at 17:05 -0400, jr.richardson at cox.net wrote:
> Hi Guys,
> I have several * servers connected to T1 PRI's from various service
providers in multiple locations the US.  All the * servers use the same
hardware with the same OS and * version.  When connected to 5ESS Switches,
using the NI2 (national) PRI protocol, the CID name and number come across
fine and populate into the * CDR fine.  I connected to a DMS-500, NI2
(national) protocol and the CID name doesn't get populated in the * CDR.
The only variance in the PRI debug outputs is this, from the DMS switch:
> Jun  9 16:41:15 WARNING[30369]: chan_zap.c:7133 zt_pri_error: PRI: !!
Facility message shorter than 14 bytes
> The interesting part is that the CID name does come into the * server and
is forwarded to the destination phone, the CID name and number does come
across from the service provider.
> I’m thinking there is something particular with the DMS-500 and *
causing this.  Is there a special terminating setting I can throw into
Zapata.conf to help this situation.
> I can send full debug outputs from both working and non-working servers if
> Any help would be greatly appreciated.
> Thanks in advance.
> JR

More information about the asterisk-dev mailing list