[svn-commits] mmichelson: trunk r127566 - /trunk/doc/janitor-projects.txt

SVN commits to the Digium repositories svn-commits at lists.digium.com
Wed Jul 2 16:09:18 CDT 2008


Author: mmichelson
Date: Wed Jul  2 16:09:18 2008
New Revision: 127566

URL: http://svn.digium.com/view/asterisk?view=rev&rev=127566
Log:
Add a janitor project to use ARRAY_LEN instead of in-line
sizeof() and division.


Modified:
    trunk/doc/janitor-projects.txt

Modified: trunk/doc/janitor-projects.txt
URL: http://svn.digium.com/view/asterisk/trunk/doc/janitor-projects.txt?view=diff&rev=127566&r1=127565&r2=127566
==============================================================================
--- trunk/doc/janitor-projects.txt (original)
+++ trunk/doc/janitor-projects.txt Wed Jul  2 16:09:18 2008
@@ -32,3 +32,11 @@
  -- Audit all channel/res/app/etc. modules to ensure that they do not register any entrypoints with the Asterisk core until after they are ready to service requests; all config file reading/processing, structure allocation, etc. must be completed before Asterisk is made aware of any services the module offers.
 
  -- Ensure that Realtime-enabled modules do not depend on the order of columns returned by the database lookup (example: outboundproxy and host settings in chan_sip).
+
+ -- There are several places in the code where the length of arrays is calculated in-line with sizeof() and division. A common place to find this is in for loops, like this:
+
+ 	for (i = 0; i < sizeof(array)/sizeof(array[0]); i++)
+
+	There is a macro in utils.h called ARRAY_LEN which should be used instead for readability's sake.
+
+	for (i = 0; i < ARRAY_LEN(array); i++)




More information about the svn-commits mailing list