[libss7-commits] mattf: trunk r155 - /trunk/isup.c

SVN commits to the libss7 project libss7-commits at lists.digium.com
Wed Apr 30 16:34:24 CDT 2008


Author: mattf
Date: Wed Apr 30 16:34:23 2008
New Revision: 155

URL: http://svn.digium.com/view/libss7?view=rev&rev=155
Log:
Make sure we don't send generic name unless it's actually set.

Modified:
    trunk/isup.c

Modified: trunk/isup.c
URL: http://svn.digium.com/view/libss7/trunk/isup.c?view=diff&rev=155&r1=154&r2=155
==============================================================================
--- trunk/isup.c (original)
+++ trunk/isup.c Wed Apr 30 16:34:23 2008
@@ -1423,6 +1423,10 @@
 static FUNC_SEND(generic_name_send)
 {
 	int namelen = strlen(c->generic_name);
+
+	/* Check to see if generic name is set before we try to add it */
+	if (!c->generic_name[0])
+		return 0;
 
 	parm[0] = (c->generic_name_typeofname << 5) | ((c->generic_name_avail & 0x1) << 4) | (c->generic_name_presentation & 0x3);
 	memcpy(&parm[1], c->generic_name, namelen);




More information about the libss7-commits mailing list