[asterisk-users] MWI with PJSIP - unsollicitated works fine, solicitated doesn't

Marek GreŇ°ko mgresko8 at gmail.com
Fri Nov 19 02:56:38 CST 2021


Hello Michael,

I was also struggling with solicited MWI after moving to pjsip. My
problem was I was defining mailbox=111 at extensioncontext. But the
correct context in the mailbox command is to be defined by context in
voicemail.conf. My voicemails were all defined in the context default
(see voicemail.conf) and the mailbox command should look like this:
mailbox=111 at default.

Hope this helps. I do not know whether this is also your problem.

Marek


2021-11-14 16:38 GMT+01:00, Mike <michael at virtutel.ca>:
> Hi,
>
>
>
> Just  recently moved over from chan_sip to PJSIP and am slowly cleaning up
> whatever needs to be.
>
>
>
> I can't seem to make sollicitated MWI work, but unsollicitated works fine.
>
>
>
>
> I got my phones subscribing to mailbox at context (i.e. 100 at whatever)
>
>
>
> I have my related AOR entry (realtime, in a DB) set to
> mailboxes=100 at whatever . I can see it is set properly by using the command
> "pjsip show aor "
>
>
>
> But when I turn pjsip logger on, I see messages from the phones
> subscribing and SIP/2.0 401 Unauthorized messages back.
>
>
>
> If I put the same column in my realtime DB (mailboxes) for ENPOINT to the
> same value (100 at whatever) then it works fine, MWI works on the phone.
>
>
>
> For a few reasons I'd like to get MWI working in sollicitated mode
> instead.  Is there a trick to it?
>
>
>
> I upgraded to Asterisk 18.8.0 just to see if a later patch fixed anything,
> so I am current.
>
>
>
>
>
>
>
>
>
>
>
>
>
> Michael
>
>



More information about the asterisk-users mailing list