[asterisk-users] Segfault on libasteriskpj.so.2

Carlos Chavez cursor at telecomab.mx
Fri Jul 20 13:18:58 CDT 2018

     I just finished installing a brand new server with CentOS 7.5 and 
Asterisk 13.22.0 and the minute I a call from the PSTN (from a SIP 
trunk) bridges with any SIP phone Asterisk crashes:

Jul 20 10:59:53 localhost kernel: asterisk[2819]: segfault at 188 ip 
00007f158b9e047c sp 00007f1568789820 error 4 in 
Jul 20 11:00:35 localhost kernel: asterisk[2925]: segfault at 188 ip 
00007f44b1ea947c sp 00007f4444700820 error 4 in 
Jul 20 11:02:05 localhost kernel: asterisk[3133]: segfault at 188 ip 
00007fe5b8f8147c sp 00007fe547737820 error 4 in 
Jul 20 11:08:25 localhost kernel: asterisk[3515]: segfault at 188 ip 
00007f65c332547c sp 00007f6551b56820 error 4 in 

     I found a closed bug: 
https://issues.asterisk.org/jira/browse/ASTERISK-27210 but the status is 
unresolved and closed.  We are not using any DNS in our configurations, 
everything is in IP notation.  Internet is somewhat slow and sometimes 
DNS fails the first time you need to resolve something.  We started on 
13.21.1 but upgraded to 13.22.0 and are still having the same problem.

     This is not the first time I have seen this segfault.  We tried a 
virtual machine some months ago with the same result.  At the time we 
though the problem was related to the very old hypervisor we were using 
but we get the same exact segfault on a new physical server.  Anyone 
else run into this bug?  Any way to fix it or is it back to chan_sip?

Telecomunicaciones Abiertas de México S.A. de C.V.
Carlos Chávez
+52 (55)8116-9161

More information about the asterisk-users mailing list