[asterisk-users] streaming audio

Jerry Geis jerry.geis at gmail.com
Mon Nov 13 07:52:10 CST 2017

hi All,

I am using 11.25.2 and musing on hold. CentOS 7.4

I am trying to setup a MusicOnHold() streaming audio.

I have one machine I tried this on and it worked. This machine is on the
I have another machine behind a firewall that does not play.
Both machines installed mpg123.

I have a windows machine behind the firewall that plays the audio stream so
firewall is not the issue.

I see no errors on the CLI, I see the MusicOnHold startup like it should -
just no audio. I took the setup directly from the internet setup that

   -- Goto (smvoice-audio-streaming,s,1)
    -- Executing [s at smvoice-audio-streaming:1] Set("SIP/401-00000000",
"CHANNEL(MUSICCLASS)=easyonhold") in new stack
    -- Executing [s at smvoice-audio-streaming:2]
MusicOnHold("SIP/401-00000000", "") in new stack
    -- Started music on hold, class 'easyonhold', on channel

also "ps ax " shows my mpg123 process running.

Thoughts ?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-users/attachments/20171113/ad9b35c8/attachment.html>

More information about the asterisk-users mailing list