[asterisk-users] Asterisk 13 on old VMware ESXI 4

Carlos Chavez cursor at telecomab.mx
Tue Aug 1 13:53:35 CDT 2017

      I am having a very tough time trying to replace an Elastix 2.X 
install running as a virtual machine on ESXI 4.  I tried using the 
Freepbx 14 ISO that installs CentOS 6 along with Asterisk 13.16 but I 
keep getting random segfaults:

[175711.476685] asterisk[2942]: segfault at 188 ip 00007fc6c41abffc sp 
00007fc608575890 error 4 in libasteriskpj.so.2[7fc6c4144000+14c000]

      I then proceeded to install a CentOS 7.3 VM and compiled Asterisk 
13.17.0 by hand.  We are still using Freepbx 14 for the front end.  We 
did some testing over the weekend and calls were coming in and out and 
all extensions were registered.  Come Monday Asterisk started 
segfaulting again with exactly the same error.  Maybe VMware is too old 
to support the newer CentOS and Asterisk?  The Elastix install is based 
on CentOS 5 and Asterisk 1.6.  I have no idea how to approach this.  It 
only segfaults when there are only more than a couple simultaneous 
calls, that is why testing with only a couple of calls worked.

      There are several core dump files but I really do not know how to 
use them for debugging Asterisk.  Any ideas?  I will try using chan_sip 
instead of PJSIP to get things running but confidence is not high.

Telecomunicaciones Abiertas de México S.A. de C.V.
Carlos Chávez
dCAP #1349
+52 (55)8116-9161

More information about the asterisk-users mailing list