[asterisk-users] Proper way to start Asterisk on CentOS 7?

Carlos Chavez cursor at telecomabmex.com
Thu May 5 12:07:37 CDT 2016

     I am having a strange problem with Asterisk 13 on a CentOS 7 
plataform.  I have several servers running on this configuration but a 
particular installation on a Dell PowerEdge 220 server is the one giving 
me the most problems.  All installations are automated via a script so 
there is no difference but the hardware.  All dependencies are installed 
and there are no errors during installation.  We use realtime mysql for 
our configurations.

     The problem comes when Asterisk is started from init.d/asterisk.  
Asterisk loads but phones will not register and the Asterisk CLI will 
not respond to commands.  Something like "pjsip show endpoints" shows 
nothing and sometimes the CLI hangs. Asterisk itself is not crashing and 
if I open another terminal I can get into the CLI even though the other 
terminal is not responding. If I start Asterisk manually from the 
command line everything works as expected, phones register and calls flow.

     I tried a systemd startup script someone published but I get the 
same result as the initd script.  I wonder why I am only getting this 
problem on the Dell 220 server but not on other servers (even a Dell T20 
server does not have the same problem).  My office server is an HP ML110 
and has been working with Asterisk 13 and CentOS 7 for over 6 months now 
with no issues.  It uses the init.d script that comes with Asterisk and 
it has never hanged.

     Anyone know if the PowerEdge 220 server has special issues with 
Linux or Asterisk in particular?  How do you recommend starting Asterisk?

Telecomunicaciones Abiertas de México S.A. de C.V.
Carlos Chávez
+52 (55)9116-91161

More information about the asterisk-users mailing list