[asterisk-users] Fax failure - RTP too short

D'Arcy J.M. Cain darcy at Vex.Net
Mon Aug 29 07:18:20 CDT 2016

I tested my fax extension with some fax machines and they worked.  I
then pointed a client at it and the first two fax machines they tried
to send to failed with the following error.

WARNING[-1][C-00022893] res_rtp_asterisk.c: RTP Read too short

I am wondering if there might be some incompatibility with some fax
machines and not others.  Or, is there a setting that I am missing.

Note that even though it is a warning

Is there some way to increase the verbosity of sendfax?  Is there some
other place I should be examining?

I am using Asterisk 11.23 on a NetBSD system.  My extension looks
something like this:

exten => sendfax,1,Verbose(0,FAX ${faxfile} to ${destination})  
  same => n,Set(FAXOPT(headerinfo)=Fax from Acme Anvils)
  same => n,Set(FAXOPT(localstationid=5555555555)
  same => n,SendFax(${faxfile})
  same => n,System(rm ${faxfile})
  same => n,Hangup()


D'Arcy J.M. Cain
System Administrator, Vex.Net
http://www.Vex.Net/ IM:darcy at Vex.Net
VoIP: sip:darcy at Vex.Net

More information about the asterisk-users mailing list